mirror of
https://git.freebsd.org/ports.git
synced 2025-05-29 09:26:27 -04:00
Add the required bits to Uses/pyqt.mk along with all the PyQt5 ports. Thankfully this commit is mostly adding new ports, as the hard work was already done in r403297 and r403662. Huge kudos to Tobias Berner <tcberner@gmail.com> and, most importantly, Guido Falsi (madpilot@) for their initial work on these ports (see D2910 in Phabricator for an earlier version of the PyQt5 patch set). PR: 204672
24 lines
764 B
Text
24 lines
764 B
Text
The Qt5 version of QScintilla is called libqscintilla2-qt5.so.
|
|
Make it be referenced this way by Qt's build system.
|
|
--- Qt4Qt5/features/qscintilla2.prf.orig 2015-04-20 14:38:24 UTC
|
|
+++ Qt4Qt5/features/qscintilla2.prf
|
|
@@ -17,9 +17,17 @@ CONFIG(debug, debug|release) {
|
|
win32: {
|
|
LIBS += -lqscintilla2d
|
|
} else {
|
|
- LIBS += -lqscintilla2
|
|
+ greaterThan(QT_MAJOR_VERSION, 4) {
|
|
+ LIBS += -lqscintilla2-qt$${QT_MAJOR_VERSION}
|
|
+ } else {
|
|
+ LIBS += -lqscintilla2
|
|
+ }
|
|
}
|
|
}
|
|
} else {
|
|
- LIBS += -lqscintilla2
|
|
+ greaterThan(QT_MAJOR_VERSION, 4) {
|
|
+ LIBS += -lqscintilla2-qt$${QT_MAJOR_VERSION}
|
|
+ } else {
|
|
+ LIBS += -lqscintilla2
|
|
+ }
|
|
}
|