ports/devel/py-blinker/files/patch-setup.py
Kubilay Kocak 3aeb750e0d devel/py-blinker: Update to 1.4
- Update PORTVERSION and distinfo checksum (1.4)
- Add LICENSE_FILE
- Enable concurrent Python support
- Add NO_ARCH (architecture independent package)
- Update test target to new test framework convention
- Patch setup.py to support standard test command [1]

Changes:

  https://github.com/jek/blinker/blob/rel-1.4/CHANGES

[1] https://github.com/jek/blinker/pull/26/
2015-12-27 06:23:14 +00:00

12 lines
360 B
Python

# Add support for standard test command
# https://github.com/jek/blinker/pull/26/
--- setup.py.orig 2015-12-27 05:36:22 UTC
+++ setup.py
@@ -37,4 +37,6 @@ setup(name="blinker",
'Topic :: Software Development :: Libraries',
'Topic :: Utilities',
],
+ tests_require=['nose'],
+ test_suite='nose.collector',
)