mirror of
https://git.freebsd.org/ports.git
synced 2025-05-05 16:07:38 -04:00
pyreadstat is a python package to read and write sas (sas7bdat, sas7bcat, xport), spps (sav, zsav, por) and stata (dta) data files into/from pandas dataframes.
14 lines
385 B
Python
14 lines
385 B
Python
--- setup.py.orig 2024-10-18 20:21:39 UTC
|
|
+++ setup.py
|
|
@@ -26,11 +26,6 @@ if PY_MAJOR_VERSION < 3 and os.name == 'nt':
|
|
if PY_MAJOR_VERSION < 3 and os.name == 'nt':
|
|
raise Exception("Python 2 is not supported on Windows.")
|
|
|
|
-cyver = int(Cython.__version__.split(".")[0])
|
|
-if cyver < 3:
|
|
- msg = "Cython version 3 or newer required"
|
|
- raise Exception(msg)
|
|
-
|
|
ext = '.pyx'
|
|
|
|
|