ports/sysutils/wmscript/files/patch-wmscript_Makefile
Rainer Hurling 5affb4474f New port: sysutils/wmscript: System monitoring dockapp for Window Maker
WMScript allows to specify a command and have the numeric result
of that command displayed in the dock app's window. Up to 5 things
to monitor, the interval is configurable.

See http://freshmeat.sourceforge.net/projects/wmscript for details.

PR:		253346
Submitted by:	Igor Pokrovsky <ip@unixway.org> (maintainer)
Approved by:	tcberner (mentor)
Differential Revision:	https://reviews.freebsd.org/D28558
2021-02-10 17:04:17 +00:00

25 lines
603 B
Text

--- wmscript/Makefile.orig 2000-01-16 13:27:20 UTC
+++ wmscript/Makefile
@@ -1,6 +1,7 @@
-LIBDIR = -L/usr/X11R6/lib
+CC?= cc
+LIBDIR = -L%%LOCALBASE%%/lib
LIBS = -lXpm -lXext -lX11
-FLAGS = -O2
+CFLAGS += -O2
OBJS = wmscript.o \
../wmgeneral/wmgeneral.o \
../wmgeneral/misc.o \
@@ -8,10 +9,10 @@ OBJS = wmscript.o \
.c.o:
- cc -I/usr/X11R6/share/include $(FLAGS) -c -Wall $< -o $*.o
+ $(CC) -I%%LOCALBASE%%/include $(CFLAGS) -c -Wall $< -o $*.o
wmscript: $(OBJS)
- cc $(FLAGS) -o wmscript $^ -lXext $(LIBDIR) $(LIBS)
+ $(CC) -o wmscript $^ -lXext $(LIBDIR) $(LIBS)
all:: wmscript