mirror of
https://git.freebsd.org/ports.git
synced 2025-05-15 08:41:51 -04:00
net/dpdk was about to expire in lieu of net/dpdk-22.11. So move net/dpdk-22.11 to dpdk. When there are multiple versions in the ports tree always keep the most latest stable version without the suffix/prefix and adjust accordingly for other versions. Approved by: portmgr (blanket)
12 lines
532 B
Text
12 lines
532 B
Text
--- config/meson.build.orig 2023-07-18 14:47:33.929900000 +0100
|
|
+++ config/meson.build 2023-07-18 14:47:36.329284000 +0100
|
|
@@ -207,6 +207,9 @@
|
|
dpdk_conf.set('RTE_BACKTRACE', cc.has_header('execinfo.h') or is_windows)
|
|
|
|
libarchive = dependency('libarchive', required: false, method: 'pkg-config')
|
|
+if not libarchive.found()
|
|
+ libarchive = cc.find_library('archive', required: false)
|
|
+endif
|
|
if libarchive.found()
|
|
dpdk_conf.set('RTE_HAS_LIBARCHIVE', 1)
|
|
# Push libarchive link dependency at the project level to support
|