ports/net/cloud-init-devel/files/patch-setup.py
Mina Galić a46960b135
net/cloud-init-devel: [New port] Customize cloud instances
Cloud-init is the industry standard multi-distribution method for
cross-platform cloud instance initialization. It is supported across all
major public cloud providers, provisioning systems for private cloud
infrastructure, and bare-metal installations. This is the development
version, it follows the git HEAD.

WWW: https://cloud-init.io/

PR:		266847
Sponsored by:	The FreeBSD Foundation

Co-authored-by:	Joseph Mingrone <jrm@FreeBSD.org>
2022-10-14 16:28:46 -03:00

11 lines
367 B
Python

--- setup.py.orig 2021-03-17 15:40:30 UTC
+++ setup.py
@@ -153,7 +153,7 @@ INITSYS_TYPES = sorted([f.partition(".")[0] for f in I
# Install everything in the right location and take care of Linux (default) and
# FreeBSD systems.
USR = "usr"
-ETC = "etc"
+ETC = "%%PREFIX%%/etc"
USR_LIB_EXEC = "usr/lib"
LIB = "lib"
if os.uname()[0] in ["FreeBSD", "DragonFly"]: