ports/sysutils/nut-devel/files/patch-configure.ac
Cy Schubert 880d5ca1e6 sysutils/nut-devel: Disable new nut_monitor feature
At the moment this new feature, a GUI to monitor nut, inconsistently
builds and installs itself. It fails to build when built under
poudriere or when using an unprivileged account. However it will
build and install when built by hand by root. Even though ./configure
(configure.ac) is supposed to support enabling and disabling the
option, this does not work. The option remains "auto" and nut_monitor
will install or not install based on some unknown at the moment
criteria.
2022-08-28 14:16:39 -07:00

20 lines
993 B
Text

--- configure.ac.orig 2022-08-25 15:32:21.256937000 -0700
+++ configure.ac 2022-08-25 15:37:36.166445000 -0700
@@ -802,7 +802,7 @@
dnl A Python GUI client application for the sysadmin desktop
dnl (not necessarily on the NUT server itself):
-NUT_ARG_WITH([nut_monitor], [install the NUT-Monitor GUI files], [auto])
+NUT_ARG_WITH([nut_monitor], [install the NUT-Monitor GUI files], [no])
NUT_ARG_WITH([pynut], [install the PyNUT module files (yes, no, app, auto)], [auto])
dnl Note: we did NUT_CHECK_PYTHON2 NUT_CHECK_PYTHON3 etc above,
dnl and if at all possible, we generate the files from .in templates
@@ -1301,7 +1301,7 @@
dnl Can we satisfy any NUT-Monitor installation request?
if test -n "${nut_with_nut_monitor_py2gtk2}${nut_with_nut_monitor_py3qt5}" ; then
case "${nut_with_nut_monitor}" in
- "auto") nut_with_nut_monitor="yes" ;;
+ "auto") nut_with_nut_monitor="no" ;;
esac
else
case "${nut_with_nut_monitor}" in