ports/science/dwave-preprocessing/files/patch-testscpp_Makefile
Yuri Victorovich df9b162e1d science/dwave-preprocessing: Update 0.5.4 → 0.6.2
Reported by:	portscout
2023-07-11 21:14:01 -07:00

21 lines
840 B
Text

--- testscpp/Makefile.orig 2023-07-06 22:19:16 UTC
+++ testscpp/Makefile
@@ -1,15 +1,15 @@
ROOT := ..
INCLUDE := $(ROOT)/dwave/preprocessing/include
SRC := $(ROOT)/dwave/preprocessing/src
-DIMOD := $(shell python -c 'import dimod; print(dimod.get_include())')
+#DIMOD := $(shell python -c 'import dimod; print(dimod.get_include())')
CATCH2 := $(ROOT)/testscpp/Catch2/single_include/
SPDLOG := $(ROOT)/extern/spdlog/include/
-FLAGS := -std=c++17 -Wall -Wno-unknown-pragmas -fcompare-debug-second -O3
+FLAGS := ${CXXFLAGS} -std=c++17 -Wall -Wno-unknown-pragmas
all: update tests
test_main.o:
- $(CXX) test_main.cpp -c
+ $(CXX) $(FLAGS) test_main.cpp -c
# Developer note: we could make this more generic, but because the package structure
# is not at all consistent and because we have so few test files I think it's clearer to