ports/net-mgmt/py-ciscoconfparse/files/patch-pyproject.toml
Kai Knoblich 0f718a2032 net-mgmt/py-ciscoconfparse: Update to 1.9.16
* Switch to PEP517 build framework.

* Convert to USE_PYTHON=pytest to simplify Makefile.

* Remove no longer required patch for newer releases of setuptools.

Changelog since 1.5.51:

https://github.com/mpenning/ciscoconfparse/compare/v1.5.51...1.9.16
2023-10-31 13:33:15 +01:00

25 lines
851 B
TOML

Just use poetry-core and remove directives that are unknown for it.
Avoid the installation of the test suite into the top of Python's site-lib.
--- pyproject.toml.orig 2023-10-29 15:08:28 UTC
+++ pyproject.toml
@@ -2,9 +2,8 @@
[build-system]
# See -> PEP 517
-requires = ["poetry>=1.5.1", "poetry-core>=1.6.1", "wheel>=0.38.4", "packaging>=23.0"]
+requires = ["poetry-core>=1.6.1", "wheel>=0.38.4", "packaging>=23.0"]
build-backend = "poetry.core.masonry.api"
-requires-python = ">=3.8.0"
##############################################################################
#
@@ -38,7 +37,6 @@ packages = [
packages = [
# Syntax -> https://python-poetry.org/docs/pyproject/#packages
{ include = "ciscoconfparse/*" },
- { include = "tests/*" },
]
# See -> https://python-poetry.org/docs/pyproject/#include-and-exclude
include = [