ports/security/py-krb5/files/patch-setup.py
Po-Chuan Hsieh e6cc56f316
security/py-krb5: Add py-krb5 0.1.1
This library provides Python functions that wraps the Kerberos 5 C API. Due to
the complex nature of this API it is highly recommended to use something like
python-gssapi which exposes the Kerberos authentication details through GSSAPI.

WWW: https://github.com/jborean93/pykrb5
2021-09-27 23:55:49 +08:00

10 lines
381 B
Python

--- setup.py.orig 2021-09-13 20:29:11 UTC
+++ setup.py
@@ -189,7 +189,6 @@ if compile_args is None:
else:
compile_args = shlex.split(run_command(f"{kc} --cflags krb5"))
- compile_args.append("-Werror")
# Python 3.8 on macOS errors on these deprecation warnings. We ignore them as things are fixed on 3.9 but the
# code still needs to compile on 3.8.