mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
In order to harvest the best entropy jitterentropy-base.c requires that the compiler not optimize out any of its code. To ensure this the cipher and randmom makefiles remove optmization options. This will work in cases where the user has specified, for instance, CFLAGS=-O3 but will not work when CFLAGS+=-O3 is specified. These makefiles will only remove the first occurrence of the optimization flag, resulting in a build failure. This patch alters the "munging" sed command to remove all optimization options. PR: 280081 MFH: 2024Q3
11 lines
634 B
Text
11 lines
634 B
Text
--- cipher/Makefile.in.orig 2024-07-13 04:19:00 UTC
|
|
+++ cipher/Makefile.in
|
|
@@ -643,7 +643,7 @@ EXTRA_libcipher_la_SOURCES = \
|
|
blake2s-amd64-avx.S blake2s-amd64-avx512.S
|
|
|
|
@ENABLE_O_FLAG_MUNGING_FALSE@o_flag_munging = cat
|
|
-@ENABLE_O_FLAG_MUNGING_TRUE@o_flag_munging = sed -e 's/[[:blank:]]-O\([2-9sgz][2-9sgz]*\)/ -O1 /' -e 's/[[:blank:]]-Ofast/ -O1 /g'
|
|
+@ENABLE_O_FLAG_MUNGING_TRUE@o_flag_munging = sed -e 's/[[:blank:]]-O\([2-9sgz][2-9sgz]*\)/ -O1 /g' -e 's/[[:blank:]]-Ofast/ -O1 /g'
|
|
@ENABLE_INSTRUMENTATION_MUNGING_FALSE@instrumentation_munging = cat
|
|
|
|
# We need to disable instrumentation for these modules as they use cc as
|