mirror of
https://git.freebsd.org/ports.git
synced 2025-05-22 11:48:35 -04:00
This update includes: Bugfixes: - InnoDB: Undo tablespaces remained unencrypted after enabling undo tablespace encryption at startup. (Bug #29477795) - InnoDB: Problematic macros introduced with undo tablespace DDL support (Bug #29324132, Bug #94243). - InnoDB: Static thread local variables defined at the wrong scope were not released at thread exit. (Bug #29305186) - Memory leaks discovered in the innochecksum (Bug #28917614, Bug #93164). New features: - MySQL C API now supports asynchronous functions for nonblocking communication with the MySQL server. - MySQL now supports a new Chinese collation, utf8mb4_zh_0900_as_cs - CMake now causes the build process to link with the llvm lld linker for Clang if it is available. Security Fix: CVE-2019-2632, CVE-2019-2693, CVE-2019-2694, CVE-2019-2695 and other fixes. More info: https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html#AppendixMSQL PR: 237399 Reported by: Brent Busby <brent@jfi.uchicago.edu> Sponsored by: The FreeBSD Foundation
73 lines
2.5 KiB
Text
73 lines
2.5 KiB
Text
--- scripts/CMakeLists.txt.orig 2018-10-07 08:44:22 UTC
|
|
+++ scripts/CMakeLists.txt
|
|
@@ -80,6 +80,7 @@ ELSE()
|
|
MESSAGE(FATAL_ERROR "Cannot concatenate files")
|
|
ENDIF()
|
|
|
|
+IF(FALSE)
|
|
# Build mysql_fix_privilege_tables.h
|
|
ADD_CUSTOM_COMMAND(
|
|
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables_sql.h
|
|
@@ -100,6 +101,7 @@ ADD_CUSTOM_TARGET(GenFixPrivs
|
|
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables_sql.h
|
|
${CMAKE_CURRENT_BINARY_DIR}/sql_commands_sys_schema.h
|
|
)
|
|
+ENDIF()
|
|
|
|
# If we do not have performance schema compiled in then sys will not work,
|
|
# so only create an empty sys database with an auto-generated file,
|
|
@@ -204,6 +206,7 @@ IF(NOT WITHOUT_SERVER)
|
|
)
|
|
ENDIF()
|
|
|
|
+IF(FALSE)
|
|
IF(UNIX)
|
|
FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
|
|
"cd ${CMAKE_BINARY_DIR} && '${CMAKE_CPACK_COMMAND}' -G TGZ --config CPackConfig.cmake\n" )
|
|
@@ -211,6 +214,7 @@ IF(UNIX)
|
|
COMMAND chmod +x ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
|
|
)
|
|
ENDIF()
|
|
+ENDIF()
|
|
|
|
# TCMalloc hacks
|
|
IF(MALLOC_LIB)
|
|
@@ -364,7 +368,7 @@ MACRO(EXTRACT_LINK_LIBRARIES target var)
|
|
LIST(REMOVE_DUPLICATES ${target}_LIB_DEPENDS)
|
|
FOREACH(lib ${${target}_LIB_DEPENDS})
|
|
# Filter out "general", it is not a library, just CMake hint
|
|
- IF(NOT lib STREQUAL "general" AND NOT ${var} MATCHES "-l${lib} ")
|
|
+ IF(NOT lib STREQUAL "general" AND NOT ${var} MATCHES "-l${lib} " AND NOT lib STREQUAL "imported_openssl" AND NOT lib STREQUAL "imported_crypto")
|
|
IF (lib MATCHES "^\\-l")
|
|
SET(${var} "${${var}} ${lib} ")
|
|
ELSEIF(lib MATCHES "^/")
|
|
@@ -372,6 +376,8 @@ MACRO(EXTRACT_LINK_LIBRARIES target var)
|
|
GET_FILENAME_COMPONENT(lib "${lib}" NAME_WE)
|
|
STRING(REGEX REPLACE "^lib" "" lib "${lib}")
|
|
SET(${var} "${${var}}-l${lib} " )
|
|
+ ELSEIF(lib STREQUAL "-pthread")
|
|
+ SET(${var} "${${var}}-pthread " )
|
|
ELSE()
|
|
SET(${var} "${${var}}-l${lib} " )
|
|
ENDIF()
|
|
@@ -454,19 +460,7 @@ ELSE()
|
|
# On Unix, most of the files end up in the bin directory
|
|
SET(mysql_config_COMPONENT COMPONENT Development)
|
|
|
|
- IF(WITH_SYSTEMD)
|
|
- SET(BIN_SCRIPTS
|
|
- mysql_config
|
|
- mysqldumpslow
|
|
- )
|
|
- ELSE()
|
|
- SET(BIN_SCRIPTS
|
|
- mysql_config
|
|
- mysqldumpslow
|
|
- mysqld_multi
|
|
- mysqld_safe
|
|
- )
|
|
- ENDIF()
|
|
+ SET(BIN_SCRIPTS mysql_config)
|
|
|
|
SET(PKGCONFIG_FILE ${LIBMYSQL_OS_OUTPUT_NAME}.pc)
|
|
STRING(REGEX REPLACE "/mysql$" "" PKGCONFIG_DIR "${INSTALL_LIBDIR}")
|