mirror of
https://git.freebsd.org/ports.git
synced 2025-05-22 11:48:35 -04:00
This update includes security fixes on issues that are mentioned on upstream critical patch report. Further info: https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html#AppendixMSQL Delete upstream-merged patches Change other local-patches according upstream changes PR: 239272 Reported by: Markus Kohlmeyer <rootservice@gmail.com> Sponsored by: EuroBSDCon 2019 DevSummit
23 lines
757 B
Text
23 lines
757 B
Text
--- libmysql/CMakeLists.txt.orig 2017-06-27 11:44:29 UTC
|
|
+++ libmysql/CMakeLists.txt
|
|
@@ -181,6 +181,11 @@ IF (WIN32 AND OPENSSL_APPLINK_C)
|
|
)
|
|
ENDIF()
|
|
|
|
+INCLUDE(${MYSQL_CMAKE_SCRIPT_DIR}/compile_flags.cmake)
|
|
+IF (CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
|
+ ADD_COMPILE_FLAGS(${CLIENT_SOURCES} COMPILE_FLAGS "-fPIC")
|
|
+ENDIF()
|
|
+
|
|
#
|
|
# Include protocol tracing infrastructure and the test
|
|
# trace plugin if enabled by build options.
|
|
@@ -254,7 +258,7 @@ IF(NOT DISABLE_SHARED)
|
|
COMPONENT SharedLibraries)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
- IF(FREEBSD OR APPLE)
|
|
+ IF(FREEBSD OR APPLE OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD|DragonFly")
|
|
SET(OS_SHARED_LIB_VERSION "${SHARED_LIB_MAJOR_VERSION}")
|
|
ELSE()
|
|
SET(OS_SHARED_LIB_VERSION
|