mirror of
https://git.freebsd.org/ports.git
synced 2025-05-21 03:23:10 -04:00
Also, SSL is only a build requirement. While here, prevent extract shared libraries from building on DragonFly. Approved by: SSL blanket
11 lines
428 B
Text
11 lines
428 B
Text
--- libmysql/CMakeLists.txt.orig 2015-02-25 21:09:49 UTC
|
|
+++ libmysql/CMakeLists.txt
|
|
@@ -254,7 +254,7 @@ IF(NOT DISABLE_SHARED)
|
|
COMPONENT SharedLibraries)
|
|
IF(UNIX)
|
|
# libtool compatability
|
|
- IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
|
|
+ IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD|DragonFly" OR APPLE)
|
|
SET(OS_SHARED_LIB_VERSION "${SHARED_LIB_MAJOR_VERSION}")
|
|
ELSE()
|
|
SET(OS_SHARED_LIB_VERSION
|