ports/math/octomap/files/patch-dynamicEDT3D_src_CMakeLists.txt

37 lines
1.5 KiB
Text

--- dynamicEDT3D/src/CMakeLists.txt.orig 2018-11-20 06:37:53 UTC
+++ dynamicEDT3D/src/CMakeLists.txt
@@ -9,28 +9,28 @@ set_target_properties(dynamicedt3d PROPE
)
target_link_libraries(dynamicedt3d ${OCTOMAP_LIBRARIES})
-add_library(dynamicedt3d-static STATIC ${dynamicEDT3D_SRCS})
-target_link_libraries(dynamicedt3d-static ${OCTOMAP_LIBRARIES})
+#add_library(dynamicedt3d-static STATIC ${dynamicEDT3D_SRCS})
+#target_link_libraries(dynamicedt3d-static ${OCTOMAP_LIBRARIES})
-SET_TARGET_PROPERTIES(dynamicedt3d-static PROPERTIES OUTPUT_NAME "dynamicedt3d")
+#SET_TARGET_PROPERTIES(dynamicedt3d-static PROPERTIES OUTPUT_NAME "dynamicedt3d")
if(NOT EXISTS "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/dynamicEDT3D")
file(MAKE_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/dynamicEDT3D")
endif()
-export(TARGETS dynamicedt3d dynamicedt3d-static
+export(TARGETS dynamicedt3d
FILE "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/cmake/dynamicEDT3D/dynamicEDT3DTargets.cmake")
# directly depend on the octomap library target when building the
# complete distribution, so it it recompiled as needed
if (CMAKE_PROJECT_NAME STREQUAL "octomap-distribution")
- ADD_DEPENDENCIES(dynamicedt3d-static octomap-static)
+ #ADD_DEPENDENCIES(dynamicedt3d-static octomap-static)
ADD_DEPENDENCIES(dynamicedt3d octomap)
endif()
ADD_SUBDIRECTORY(examples)
-install(TARGETS dynamicedt3d dynamicedt3d-static
+install(TARGETS dynamicedt3d
EXPORT dynamicEDT3DTargets
INCLUDES DESTINATION include
${INSTALL_TARGETS_DEFAULT_ARGS}