ports/x11/libxkbcommon/files/patch-meson.build
Baptiste Daroussin 496919e487 x11/libxkbcommon: fix issue with version-script and recently linker
The test used in the meson file is valid on linux but invalid on FreeBSD
it tested while building a binary instead of a DSO.

Adding -shared to the argument of the tests makes it pass properly

Note: that this is invisible on current due to a change in the base which
is probably a bug and under investigation

PR:		285325
Reported by:	many
2025-03-21 11:19:35 +01:00

11 lines
407 B
Text

--- meson.build.orig 2025-03-11 23:24:11 UTC
+++ meson.build
@@ -168,7 +168,7 @@ have_version_script = cc.links(
meson_test_map = meson.current_source_dir() / 'test/meson_test.map'
have_version_script = cc.links(
'int main() { return 0; }',
- args: f'-Wl,--version-script=@meson_test_map@',
+ args: ['-shared', f'-Wl,--version-script=@meson_test_map@'],
name: '-Wl,--version-script',
)