mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
19 lines
653 B
Text
19 lines
653 B
Text
--- src/SFML/Audio/Makefile.orig 2010-01-27 15:00:19.000000000 +0100
|
|
+++ src/SFML/Audio/Makefile 2013-02-14 09:39:53.000000000 +0100
|
|
@@ -19,13 +19,13 @@
|
|
$(AR) $(ARFLAGS) $(LIBNAME) $(OBJ) $(OBJVORBIS)
|
|
|
|
libsfml-audio.so: $(OBJ) $(OBJVORBIS)
|
|
- $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJVORBIS) -lsndfile -lopenal
|
|
+ $(CXX) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJVORBIS) -lsndfile -lopenal
|
|
|
|
$(OBJ): %.o: %.cpp
|
|
- $(CPP) -o $@ -c $< $(CFLAGS)
|
|
+ $(CXX) -o $@ -c $< $(CXXFLAGS)
|
|
|
|
$(OBJVORBIS): %.o: %.c
|
|
- $(CC) -o $@ -c $< $(CFLAGSEXT)
|
|
+ $(CC) -o $@ -c $< $(CFLAGS)
|
|
|
|
.PHONY: clean mrproper
|
|
|