ports/devel/hadoop/files/patch-src-c++-pipes-impl-HadoopPipes.cc
Tijl Coosemans 0ea25d146e - Update Apache Hadoop to version 1.2.1.
- Hand maintainership to submitter.
- Replace HADOOP_HOME with DATADIR and HADOOP_ETC with ETCDIR.
- Replace pkg-install and pkg-deinstall with pkg-plist entries.
- Support staging.
- Fix build on FreeBSD 10 (clang, libc++, hardcoded gcc).

PR:		ports/183307
Submitted by:	Pedro Giffuni <pfg@apache.org>
2013-11-02 11:04:31 +00:00

10 lines
313 B
C++

--- src/c++/pipes/impl/HadoopPipes.cc.orig 2013-07-23 00:26:40.000000000 +0200
+++ src/c++/pipes/impl/HadoopPipes.cc 2013-10-30 15:42:33.000000000 +0100
@@ -34,6 +34,7 @@
#include <pthread.h>
#include <iostream>
#include <fstream>
+#include <unistd.h>
#include <openssl/hmac.h>
#include <openssl/buffer.h>