ports/cad/openroad/files/patch-CMakeLists.txt
Thierry Thomas 040ccec12e cad/openroad: Fix with libfmt >= 9
PR:		268513
2022-12-22 11:35:57 -08:00

12 lines
446 B
Text

--- CMakeLists.txt.orig 2022-02-09 14:58:23 UTC
+++ CMakeLists.txt
@@ -45,6 +45,9 @@ if(CMAKE_VERSION VERSION_GREATER_EQUAL 3.10)
cmake_policy(SET CMP0071 NEW)
endif()
+# Fix with FMT >= 9 - see https://github.com/The-OpenROAD-Project/OpenROAD/issues/2386
+add_compile_definitions(FMT_DEPRECATED_OSTREAM)
+
# Interfers with Qt so off by default.
option(LINK_TIME_OPTIMIZATION "Flag to control link time optimization: off by default" OFF)