ports/net/freerdp/files/patch-client_X11_CMakeLists.txt
Carlos J. Puga Medina 6937c98e2b net/freerdp: Update to 2.0.0-rc1
- Enable 64 bit file support in winpr
- Remove unneeded patches (added upstream)
- Add support for ICU for unicode conversion
- Add support for KERBEROS
- Add MANPAGES option and fix man pages installation in /usr/local/man
- Fix WWW in pkg-descr
- Pet portlint

Changelog: https://github.com/FreeRDP/FreeRDP/blob/2.0.0-rc1/ChangeLog

PR:		224658
Submitted by:	cpm
Reviewed by:	kevans
Approved by:	kevans (maintainer)
2018-01-04 19:37:58 +00:00

15 lines
568 B
Text

--- client/X11/CMakeLists.txt.orig 2017-11-28 14:26:30 UTC
+++ client/X11/CMakeLists.txt
@@ -111,7 +111,11 @@ if(WITH_MANPAGES)
add_custom_target(xfreerdp.manpage ALL
DEPENDS xfreerdp.1)
- install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 1)
+ if(BSD)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 DESTINATION man/man1)
+ else()
+ install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 1)
+ endif()
else()
message(WARNING "WITH_MANPAGES was set, but xsltproc was not found. man-pages will not be installed")
endif()