mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
- Enable 64 bit file support in winpr - Remove unneeded patches (added upstream) - Add support for ICU for unicode conversion - Add support for KERBEROS - Add MANPAGES option and fix man pages installation in /usr/local/man - Fix WWW in pkg-descr - Pet portlint Changelog: https://github.com/FreeRDP/FreeRDP/blob/2.0.0-rc1/ChangeLog PR: 224658 Submitted by: cpm Reviewed by: kevans Approved by: kevans (maintainer)
15 lines
568 B
Text
15 lines
568 B
Text
--- client/X11/CMakeLists.txt.orig 2017-11-28 14:26:30 UTC
|
|
+++ client/X11/CMakeLists.txt
|
|
@@ -111,7 +111,11 @@ if(WITH_MANPAGES)
|
|
add_custom_target(xfreerdp.manpage ALL
|
|
DEPENDS xfreerdp.1)
|
|
|
|
- install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 1)
|
|
+ if(BSD)
|
|
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 DESTINATION man/man1)
|
|
+ else()
|
|
+ install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/xfreerdp.1 1)
|
|
+ endif()
|
|
else()
|
|
message(WARNING "WITH_MANPAGES was set, but xsltproc was not found. man-pages will not be installed")
|
|
endif()
|