mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
- Enable 64 bit file support in winpr - Remove unneeded patches (added upstream) - Add support for ICU for unicode conversion - Add support for KERBEROS - Add MANPAGES option and fix man pages installation in /usr/local/man - Fix WWW in pkg-descr - Pet portlint Changelog: https://github.com/FreeRDP/FreeRDP/blob/2.0.0-rc1/ChangeLog PR: 224658 Submitted by: cpm Reviewed by: kevans Approved by: kevans (maintainer)
16 lines
674 B
Text
16 lines
674 B
Text
--- client/Wayland/CMakeLists.txt.orig 2017-11-28 14:26:30 UTC
|
|
+++ client/Wayland/CMakeLists.txt
|
|
@@ -39,5 +39,12 @@ target_link_libraries(${MODULE_NAME} ${$
|
|
install(TARGETS ${MODULE_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR} COMPONENT client)
|
|
|
|
set_property(TARGET ${MODULE_NAME} PROPERTY FOLDER "Client/Wayland")
|
|
+
|
|
+if(WITH_MANPAGES)
|
|
configure_file(wlfreerdp.1.in ${CMAKE_CURRENT_BINARY_DIR}/wlfreerdp.1)
|
|
-install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/wlfreerdp.1 1)
|
|
+ if(BSD)
|
|
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/wlfreerdp.1 DESTINATION man/man1)
|
|
+ else()
|
|
+ install_freerdp_man(${CMAKE_CURRENT_BINARY_DIR}/wlfreerdp.1 1)
|
|
+ endif()
|
|
+endif(WITH_MANPAGES)
|