mirror of
https://git.freebsd.org/ports.git
synced 2025-05-21 11:33:15 -04:00
is disabled by default because MIDI plugin for OSS does not exist, i.e., (hardware) MIDI sequencer is not supported. However, softsynth (Gervill) works fine as it uses sampled sound.
36 lines
1.2 KiB
Diff
36 lines
1.2 KiB
Diff
--- jdk/make/javax/sound/Makefile 2011-01-20 18:54:05.000000000 -0500
|
|
+++ jdk/make/javax/sound/Makefile 2011-02-11 16:20:52.000000000 -0500
|
|
@@ -105,6 +105,15 @@
|
|
#MXSPP_ADD = $(PLATFORM)-$(ARCH)/
|
|
endif # PLATFORM linux
|
|
|
|
+ifeq ($(PLATFORM), bsd)
|
|
+ # build with empty MIDI i/o
|
|
+ INCLUDE_MIDI = TRUE
|
|
+ # ALSA handles directaudio and ports
|
|
+ SUBDIRS += jsoundalsa
|
|
+ EXTRA_SOUND_JNI_LIBS += jsoundalsa
|
|
+ #MXSPP_ADD = $(PLATFORM)-$(ARCH)/
|
|
+endif # PLATFORM bsd
|
|
+
|
|
ifeq ($(PLATFORM), solaris)
|
|
ifneq ($(ARCH), amd64)
|
|
# build with ports and direct audio
|
|
--- jdk/src/share/native/com/sun/media/sound/Platform.c 2011-01-20 18:54:37.000000000 -0500
|
|
+++ jdk/src/share/native/com/sun/media/sound/Platform.c 2011-02-11 16:20:52.000000000 -0500
|
|
@@ -99,5 +99,15 @@
|
|
return com_sun_media_sound_Platform_LIB_ALSA;
|
|
}
|
|
#endif
|
|
+#if (X_PLATFORM == X_BSD)
|
|
+ switch (feature) {
|
|
+ case com_sun_media_sound_Platform_FEATURE_MIDIIO:
|
|
+ return com_sun_media_sound_Platform_LIB_MAIN;
|
|
+ case com_sun_media_sound_Platform_FEATURE_PORTS:
|
|
+ return com_sun_media_sound_Platform_LIB_ALSA;
|
|
+ case com_sun_media_sound_Platform_FEATURE_DIRECT_AUDIO:
|
|
+ return com_sun_media_sound_Platform_LIB_ALSA;
|
|
+ }
|
|
+#endif
|
|
return 0;
|
|
}
|