ports/textproc/zorba/files/patch-swig_ZorbaIOStream.i
John Marino 1428ba3700 textproc/zorba: Modernize options, support DragonFly
* Corrected an old-style LIB_DEPENDS callout
  * Used OPTION_SUB (and adjusted pkg-plist as a consequence)
  * Brought CMAKE args into options
  * Used sed to allow building on DragonFly
  * Fix swig build on F10+
  * Fix no-docs option
2015-03-26 19:18:49 +00:00

18 lines
551 B
OpenEdge ABL

--- swig/ZorbaIOStream.i.orig 2012-10-03 22:35:16 UTC
+++ swig/ZorbaIOStream.i
@@ -46,7 +46,7 @@ void ZorbaIOStream::setStream(const char
void ZorbaIOStream::setStream(const char *BYTE, size_t aLen)
{
- if (aLen<0) aLen=0;
+ /* if (aLen<0) aLen=0; size_t is unsigned, check always fails */
if (aLen > 0)
memcpy(buffer, BYTE, aLen*sizeof(char));
len = aLen;
@@ -71,4 +71,4 @@ void ZorbaIOStream::write(const char *BY
%} // end Implementation
-%include "ZorbaIOStream.h"
\ No newline at end of file
+%include "ZorbaIOStream.h"