ports/textproc/uncrustify/files/patch-CMakeLists.txt
2017-05-22 14:32:25 +00:00

35 lines
1.1 KiB
Text

--- CMakeLists.txt.orig 2017-05-18 15:15:24 UTC
+++ CMakeLists.txt
@@ -116,32 +116,6 @@ endif()
#
# Generate uncrustify_version.h
#
-
-# FIXME: checking for CMAKE_BUILD_TYPE and passing it to make_version.py
-# does not work with VS .sln projects
-if(NOT CMAKE_BUILD_TYPE)
- set(CMAKE_BUILD_TYPE Release)
-endif()
-# FIXME: the version number should be automatically integrated
-set(FALLBACK_VERSION "Uncrustify-0.65_f")
-
-find_package(PythonInterp REQUIRED)
-execute_process(
- COMMAND ${PYTHON_EXECUTABLE} scripts/make_version.py ${CMAKE_BUILD_TYPE}
- WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
- RESULT_VARIABLE make_version_error
- OUTPUT_VARIABLE make_version_output
-)
-
-message(STATUS )
-if (make_version_error)
- message(WARNING "scripts/make_version.py exited with code ${make_version_error}: ${make_version_output}\n"
- "As a fallback, version '${FALLBACK_VERSION}' will be used.")
- set( CURRENT_VERSION ${FALLBACK_VERSION} )
-else()
- string(STRIP ${make_version_output} CURRENT_VERSION)
-endif()
-
configure_file(src/uncrustify_version.h.in uncrustify_version.h @ONLY)
#