ports/textproc/py-sphinx_numfig/files/patch-setup.py
Kris Moore c2762ac624 This is a Sphinx package for autonumbering figures. With numfig you can
have numbered figures in your Sphinx documents and refer to them by number.

WWW: https://bitbucket.org/arjones6/sphinx-numfig/wiki/Home
2015-09-12 13:36:35 +00:00

20 lines
640 B
Python

--- setup.py.orig 2012-10-08 16:34:53 UTC
+++ setup.py
@@ -19,7 +19,7 @@ else:
sys.exit(1)
# Remove the old installation
-sphinxdir = os.path.dirname(sphinx.__file__)
+sphinxdir = sys.argv[2]
olddst = os.path.join(sphinxdir, "numfig.py")
olddstc = os.path.join(sphinxdir, "numfig.pyc")
sphinxextdir = os.path.join(sphinxdir, "ext")
@@ -39,7 +39,7 @@ shutil.copyfile("numfig.py", dst)
# Compile to bytecode
import py_compile
print "Compiling", dst, "to bytecode."
-py_compile.compile(dst)
+py_compile.compile(dst, dstc, sys.argv[3])
# Fix perms
mode = stat.S_IRUSR | stat.S_IWUSR | stat.S_IRGRP | stat.S_IWGRP | stat.S_IROTH