ports/sysutils/radmind/files/patch-mkdirs.c
Thomas Zander 79c08ab7c5 - Update to new revision 2014052201
- Stagify
- Add LICENSE*
- Remove IGNORE_TIMESTAMPS option
- Handle file ownerships via pkg-plist macros
- Silence superfluous warnings
- Handle stripping of installed binaries
- Pet portlint

PR:		190120
Submitted by:	mikeg@bsd-box.net (maintainer)
Reviewed by:	riggs
Approved by:	mentors (implicit), maintainer (timeout)
2014-07-12 09:31:02 +00:00

13 lines
312 B
C

--- ./mkdirs.c.orig 2010-12-13 04:42:49.000000000 +0100
+++ ./mkdirs.c 2014-06-29 12:15:04.247544144 +0200
@@ -37,7 +37,9 @@
if ( mkdir( path, 0777 ) == 0 ) {
break;
}
- if ( errno != ENOENT ) {
+ if ( errno == EEXIST ) {
+ break;
+ } else if ( errno != ENOENT ) {
return( -1 );
}
q = p;