mirror of
https://git.freebsd.org/ports.git
synced 2025-05-17 09:33:11 -04:00
port depends on to 8.6, bump PORTREVISION - Add patch fixing build with TCL 8.6 - Regenerate patches with make makepatch PR: 211690 Submitted by: Matthieu Volat
62 lines
3.8 KiB
Text
62 lines
3.8 KiB
Text
--- configure.orig 2012-12-19 17:02:25 UTC
|
|
+++ configure
|
|
@@ -1480,7 +1480,7 @@ Optional Packages:
|
|
specify a pattern for trace [[no]]
|
|
--with-tcl=<dir> directory containing tcl configuration
|
|
(tclConfig.sh) [[searches]]
|
|
- --with-tcl-ver=X.Y Tcl version to use [[search]]
|
|
+ --with-tcl-ver=XY Tcl version to use [[search]]
|
|
--with-tcl-lib=<dir> directory containing tcl libraries (libtclX.Y)
|
|
[[none]]
|
|
--with-tcl-inc=<dir> directory containing tcl include files
|
|
@@ -1518,7 +1518,7 @@ PREFIX/Modules/($MODULES_VERSION/ if mod
|
|
init/
|
|
man/
|
|
man1/
|
|
- man4/
|
|
+ man5/
|
|
modulefiles/
|
|
PREFIX/Modules/
|
|
modulefiles/
|
|
@@ -7099,9 +7099,9 @@ else
|
|
em_cv_tclver=${with_tclver}
|
|
fi #}}
|
|
|
|
- tclver=`echo $em_cv_tclver | sed -n -e '/[0-9]\.[0-9]/p'`
|
|
+ tclver=`echo $em_cv_tclver | sed -n -e '/[0-9][0-9]/p'`
|
|
if test x"$tclver" = x ; then #{
|
|
- as_fn_error $? "Must specify version (X.Y) if using this option" "$LINENO" 5
|
|
+ as_fn_error $? "Must specify version (XY) if using this option" "$LINENO" 5
|
|
fi #}
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${em_cv_tclver}" >&5
|
|
$as_echo "${em_cv_tclver}" >&6; }
|
|
@@ -7375,9 +7375,9 @@ else
|
|
em_cv_tclxver=${with_tclxver}
|
|
fi #}}
|
|
|
|
- tclxver=`echo $em_cv_tclxver | sed -n -e '/[0-9]\.[0-9]/p'`
|
|
+ tclxver=`echo $em_cv_tclxver | sed -n -e '/[0-9][0-9]/p'`
|
|
if test x"$tclxver" = x ; then #{
|
|
- as_fn_error $? "Must specify version (X.Y) if using this option" "$LINENO" 5
|
|
+ as_fn_error $? "Must specify version (XY) if using this option" "$LINENO" 5
|
|
fi #}
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using ${em_cv_tclxver}" >&5
|
|
$as_echo "using ${em_cv_tclxver}" >&6; }
|
|
@@ -7657,7 +7657,7 @@ else
|
|
EXTDIR="etc"
|
|
|
|
fi
|
|
-ac_config_files="$ac_config_files Makefile modules.lsm .spec doc/Makefile init/Makefile init/.modulespath doc/module.1 doc/modulefile.4 etc/Makefile etc/add.modules etc/mkroot etc/skel/.cshrc etc/skel/.login etc/skel/.kshenv etc/skel/.profile etc/global/csh.cshrc etc/global/csh.login etc/global/csh.modules etc/global/bashrc etc/global/profile etc/global/profile.modules ext/Makefile ext/add.ext ext/mkroot ext/common/.cshrc ext/common/.login ext/common/.kshenv ext/common/.profile modulefiles/Makefile modulefiles/modules modulefiles/module-git modulefiles/module-info modulefiles/null modulefiles/use.own modulefiles/dot modulefiles/version"
|
|
+ac_config_files="$ac_config_files Makefile modules.lsm .spec doc/Makefile init/Makefile init/.modulespath doc/module.1 doc/modulefile.5 etc/Makefile etc/add.modules etc/mkroot etc/skel/.cshrc etc/skel/.login etc/skel/.kshenv etc/skel/.profile etc/global/csh.cshrc etc/global/csh.login etc/global/csh.modules etc/global/bashrc etc/global/profile etc/global/profile.modules ext/Makefile ext/add.ext ext/mkroot ext/common/.cshrc ext/common/.login ext/common/.kshenv ext/common/.profile modulefiles/Makefile modulefiles/modules modulefiles/module-git modulefiles/module-info modulefiles/null modulefiles/use.own modulefiles/dot modulefiles/version"
|
|
ac_config_commands="$ac_config_commands default"
|
|
cat >confcache <<\_ACEOF
|
|
# This file is a shell script that caches the results of configure
|
|
@@ -8398,7 +8398,7 @@ do
|
|
"init/Makefile") CONFIG_FILES="$CONFIG_FILES init/Makefile" ;;
|
|
"init/.modulespath") CONFIG_FILES="$CONFIG_FILES init/.modulespath" ;;
|
|
"doc/module.1") CONFIG_FILES="$CONFIG_FILES doc/module.1" ;;
|
|
- "doc/modulefile.4") CONFIG_FILES="$CONFIG_FILES doc/modulefile.4" ;;
|
|
+ "doc/modulefile.5") CONFIG_FILES="$CONFIG_FILES doc/modulefile.5" ;;
|
|
"etc/Makefile") CONFIG_FILES="$CONFIG_FILES etc/Makefile" ;;
|
|
"etc/add.modules") CONFIG_FILES="$CONFIG_FILES etc/add.modules" ;;
|
|
"etc/mkroot") CONFIG_FILES="$CONFIG_FILES etc/mkroot" ;;
|