mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
Please DO NOT use this version in production, it is an early test version. For upgrade notes please visit: https://github.com/php/php-src/blob/php-8.4.0alpha1/UPGRADING Changelog: https://github.com/php/php-src/blob/php-8.4.0alpha1/NEWS
19 lines
1.2 KiB
Text
19 lines
1.2 KiB
Text
--- build/Makefile.global.orig 2024-07-02 13:43:13 UTC
|
|
+++ build/Makefile.global
|
|
@@ -91,14 +91,14 @@ test: all
|
|
@if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
|
|
INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
|
|
if test "$$INI_FILE"; then \
|
|
- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini; \
|
|
+ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini || :; \
|
|
else \
|
|
echo > $(top_builddir)/tmp-php.ini; \
|
|
fi; \
|
|
INI_SCANNED_PATH=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r '$$a = explode(",\n", trim(php_ini_scanned_files())); echo $$a[0];' 2> /dev/null`; \
|
|
if test "$$INI_SCANNED_PATH"; then \
|
|
INI_SCANNED_PATH=`$(top_srcdir)/build/shtool path -d $$INI_SCANNED_PATH`; \
|
|
- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini; \
|
|
+ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini || :; \
|
|
fi; \
|
|
TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
|
|
TEST_PHP_SRCDIR=$(top_srcdir) \
|