ports/comms/snap7/files/patch-mips__bsd.mk
Kurt Jaeger 09a2b5640f New port: comms/snap7
Snap7, through three specialized components: Client and the inedited Server
and Partner, allows you to definitively integrate your PC based systems into
a PLC automation chain.

Designed to transfer large amounts of hi-speed data in industrial facilities,
it scales easily, down to small Linux Arm boards such as Raspberry PI.

Hi level object oriented wrappers are provided, currently C/C++, .NET/Mono,
Pascal, LabVIEW, Python with many source code examples.

Very detailed documentation provided.

WWW: http://sourceforge.net/projects/snap7/

PR:		215409
Submitted by:	vova@fbsd.ru
2019-01-06 13:33:31 +00:00

15 lines
274 B
Makefile

--- mips_bsd.mk.orig 2016-12-20 10:44:15 UTC
+++ mips_bsd.mk
@@ -0,0 +1,12 @@
+##
+## mips BSD based (FreeBSD etc.) Makefile
+## Use gmake instead of make
+##
+TargetCPU :=mips
+OS :=bsd
+CXXFLAGS := -O3 -fPIC -pedantic
+
+# Standard part
+
+include common.mk
+