mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
Snap7, through three specialized components: Client and the inedited Server and Partner, allows you to definitively integrate your PC based systems into a PLC automation chain. Designed to transfer large amounts of hi-speed data in industrial facilities, it scales easily, down to small Linux Arm boards such as Raspberry PI. Hi level object oriented wrappers are provided, currently C/C++, .NET/Mono, Pascal, LabVIEW, Python with many source code examples. Very detailed documentation provided. WWW: http://sourceforge.net/projects/snap7/ PR: 215409 Submitted by: vova@fbsd.ru
21 lines
889 B
Makefile
21 lines
889 B
Makefile
--- common.mk.orig 2014-04-16 08:16:20 UTC
|
|
+++ common.mk
|
|
@@ -22,7 +22,9 @@ LinkOptions := -O3
|
|
IncludePath := $(IncludeSwitch). $(IncludeSwitch)../../src/sys $(IncludeSwitch)../../src/core $(IncludeSwitch)../../src/lib
|
|
Libs := $(LibrarySwitch)pthread $(LibrarySwitch)rt
|
|
LibPath := $(LibraryPathSwitch).
|
|
-LibInstall := /usr/lib
|
|
+LibInstall := $(DESTDIR)/$(PREFIX)/lib
|
|
+IncInstall := $(DESTDIR)/$(PREFIX)/include
|
|
+WrapperInstall := $(DESTDIR)/$(PREFIX)/share/examples/snap7/c-cpp
|
|
|
|
##
|
|
## Common variables (CXXFLAGS varies across platforms)
|
|
@@ -108,4 +110,6 @@ clean:
|
|
|
|
install: all
|
|
cp -f $(OutputFile) $(LibInstall)
|
|
-
|
|
+ cp -f ../../release/Wrappers/c-cpp/snap7.h $(IncInstall)
|
|
+ $(MakeDirCommand) $(WrapperInstall)
|
|
+ cp -f ../../release/Wrappers/c-cpp/snap7.cpp $(WrapperInstall)
|