mirror of
https://git.freebsd.org/ports.git
synced 2025-05-22 19:56:53 -04:00
- virtio-net: allow masking of notifications on empty queue (Alex Williamson) - e1000: fix rx descriptor low threshold logic (Alex Willaimson) - x86 tcg: add NULL checks to lsl instruction (Jan Kiszka) - kvm vga: fix screen corruption with -std-vga and Windows (Avi Kivity) - kvm vga: fix screen corruption with Ubuntu installations (Glauber Costa) - virtio-net: check right return size on sg list (Alex Williamson) - Make qemu_announce_self handle holes (live migration after hotplug) (Marcelo Tosatti) - Revert r6804-r6808 (qcow2 allocation info). This series of changes added a high cost to startup for large qcow2 images (Anthony Liguori) - qemu-img: fix help message (Aurelien Jarno) - Fix build for non-default installs of SDL (Anthony Liguori) - Fix race condition in env->interrupt_request. When using TCG and a dynticks host timer, this condition could cause TCG to get stuck in an infinite loop (Aurelien Jarno) - Fix reading encrypted hard disk passwords during early startup (Jan Kiszka) - Fix encrypted disk reporting in 'info block' (Jan Kiszka) - Fix console size with tiny displays (MusicPal) (Jan Kiszka) - Improve error handling in bdrv_open2 (Jan Kiszka) - Avoid leaking data in mux'ed character devices (Jan Kiszka) - Fix initial character device reset (no banner in monitor) (Jan Kiszka) - Fix cpuid KVM crash on i386 host (Lubomir Rintel) - Fix SLES10sp2 installation by adding ISTAT1 register to LSI SCSI emulation (Ryan Harper) - Add physical CDROM fixes (still not perfect tho, see pkg-message) - Add MAKE_JOBS_SAFE fix and mark as such
177 lines
6 KiB
Text
177 lines
6 KiB
Text
Index: qemu/Makefile
|
|
@@ -38,7 +38,10 @@
|
|
LIBS+=-lwinmm -lws2_32 -liphlpapi
|
|
endif
|
|
|
|
-all: $(TOOLS) $(DOCS) recurse-all
|
|
+all: bsd/libmath.a $(TOOLS) $(DOCS) recurse-all
|
|
+
|
|
+bsd/libmath.a:
|
|
+ ( cd bsd ; unset MAKEFLAGS ; $(BSD_MAKE) CC=$(CC) )
|
|
|
|
SUBDIR_RULES=$(patsubst %,subdir-%, $(TARGET_DIRS))
|
|
|
|
@@ -195,6 +198,7 @@
|
|
|
|
clean:
|
|
# avoid old build problems by removing potentially incorrect old files
|
|
+ ( cd bsd ; $(BSD_MAKE) clean )
|
|
rm -f config.mak config.h op-i386.h opc-i386.h gen-op-i386.h op-arm.h opc-arm.h gen-op-arm.h
|
|
rm -f *.o *.d *.a $(TOOLS) TAGS cscope.* *.pod *~ */*~
|
|
rm -f slirp/*.o slirp/*.d audio/*.o audio/*.d
|
|
Index: qemu/Makefile.target
|
|
@@ -417,7 +417,7 @@
|
|
# WARNING: this LDFLAGS is _very_ tricky : qemu is an ELF shared object
|
|
# that the kernel ELF loader considers as an executable. I think this
|
|
# is the simplest way to make it self virtualizable!
|
|
-LDFLAGS+=-Wl,-shared
|
|
+#LDFLAGS+=-Wl,-shared
|
|
endif
|
|
endif
|
|
|
|
@@ -491,7 +491,7 @@
|
|
# cpu_signal_handler() in cpu-exec.c.
|
|
signal.o: CFLAGS += $(HELPER_CFLAGS)
|
|
|
|
-$(QEMU_PROG): $(OBJS) ../libqemu_user.a
|
|
+$(QEMU_PROG): $(OBJS) ../libqemu_user.a ../bsd/libmath.a
|
|
$(LINK)
|
|
|
|
endif #CONFIG_BSD_USER
|
|
@@ -717,9 +717,9 @@
|
|
main.o: CFLAGS+=-p
|
|
endif
|
|
|
|
-$(QEMU_PROG): LIBS += $(SDL_LIBS) $(COCOA_LIBS) $(CURSES_LIBS) $(BRLAPI_LIBS) $(VDE_LIBS)
|
|
+$(QEMU_PROG): LIBS += $(SDL_LIBS) $(COCOA_LIBS) $(CURSES_LIBS) $(BRLAPI_LIBS) $(VDE_LIBS) ../bsd/libmath.a
|
|
|
|
-$(QEMU_PROG): $(OBJS) ../libqemu_common.a libqemu.a
|
|
+$(QEMU_PROG): $(OBJS) ../libqemu_common.a libqemu.a ../bsd/libmath.a
|
|
$(LINK)
|
|
|
|
endif # !CONFIG_USER_ONLY
|
|
Index: qemu/fpu/softfloat-native.c
|
|
@@ -2,11 +2,16 @@
|
|
context is supported */
|
|
#include "softfloat.h"
|
|
#include <math.h>
|
|
+#if defined(__FreeBSD__) && __FreeBSD_version < 500000
|
|
+#include <ieeefp.h>
|
|
+#endif
|
|
|
|
void set_float_rounding_mode(int val STATUS_PARAM)
|
|
{
|
|
STATUS(float_rounding_mode) = val;
|
|
-#if defined(_BSD) && !defined(__APPLE__) || (defined(HOST_SOLARIS) && HOST_SOLARIS < 10)
|
|
+#if defined(_BSD) && !defined(__APPLE__) && !defined(__FreeBSD__) || \
|
|
+ (defined(__FreeBSD__) && __FreeBSD_version < 500000) || \
|
|
+ (defined(HOST_SOLARIS) && HOST_SOLARIS < 10)
|
|
fpsetround(val);
|
|
#elif defined(__arm__)
|
|
/* nothing to do */
|
|
@@ -22,7 +25,7 @@
|
|
}
|
|
#endif
|
|
|
|
-#if defined(_BSD) || (defined(HOST_SOLARIS) && HOST_SOLARIS < 10)
|
|
+#if (defined(_BSD) && !defined(__FreeBSD__)) || (defined(HOST_SOLARIS) && HOST_SOLARIS < 10)
|
|
#define lrint(d) ((int32_t)rint(d))
|
|
#define llrint(d) ((int64_t)rint(d))
|
|
#define lrintf(f) ((int32_t)rint(f))
|
|
Index: qemu/fpu/softfloat-native.h
|
|
@@ -1,8 +1,28 @@
|
|
/* Native implementation of soft float functions */
|
|
#include <math.h>
|
|
|
|
-#if (defined(_BSD) && !defined(__APPLE__)) || defined(HOST_SOLARIS)
|
|
+#ifdef __FreeBSD__
|
|
+#include <osreldate.h>
|
|
+long double fabsl(long double x);
|
|
+long double remainderl(long double x, long double y);
|
|
+long double sqrtl(long double x);
|
|
+long double rintl(long double x);
|
|
+long lrintl(long double x);
|
|
+long long llrintl(long double x);
|
|
+#endif
|
|
+
|
|
+#if (defined(_BSD) && !defined(__APPLE__) && \
|
|
+ (!defined(__FreeBSD__) || __FreeBSD_version < 500000)) || \
|
|
+ defined(HOST_SOLARIS)
|
|
#include <ieeefp.h>
|
|
+#if defined(__FreeBSD__)
|
|
+#define isgreater(x, y) __builtin_isgreater((x), (y))
|
|
+#define isgreaterequal(x, y) __builtin_isgreaterequal((x), (y))
|
|
+#define isless(x, y) __builtin_isless((x), (y))
|
|
+#define islessequal(x, y) __builtin_islessequal((x), (y))
|
|
+#define islessgreater(x, y) __builtin_islessgreater((x), (y))
|
|
+#define isunordered(x, y) __builtin_isunordered((x), (y))
|
|
+#endif
|
|
#define fabsf(f) ((float)fabs(f))
|
|
#else
|
|
#include <fenv.h>
|
|
@@ -109,6 +109,8 @@
|
|
| Software IEC/IEEE floating-point rounding mode.
|
|
*----------------------------------------------------------------------------*/
|
|
-#if (defined(_BSD) && !defined(__APPLE__)) || defined(HOST_SOLARIS)
|
|
+#if (defined(_BSD) && !defined(__APPLE__) && \
|
|
+ (!defined(__FreeBSD__) || __FreeBSD_version < 500000)) || \
|
|
+ defined(HOST_SOLARIS)
|
|
#if defined(__OpenBSD__)
|
|
#define FE_RM FP_RM
|
|
#define FE_RP FP_RP
|
|
Index: qemu/fpu/softfloat.h
|
|
@@ -84,7 +84,8 @@
|
|
#define FLOAT128
|
|
#else
|
|
/* native float support */
|
|
-#if (defined(__i386__) || defined(__x86_64__)) && !defined(_BSD)
|
|
+#if (defined(__i386__) || defined(__x86_64__)) && \
|
|
+ (!defined(_BSD) || defined(__FreeBSD__))
|
|
#define FLOATX80
|
|
#endif
|
|
#endif /* !CONFIG_SOFTFLOAT */
|
|
Index: qemu/target-ppc/op_helper.c
|
|
@@ -293,6 +293,13 @@
|
|
uint32_t exp = (u.ll >> 52) & 0x7FF;
|
|
return ((0 < exp) && (exp < 0x7FF));
|
|
}
|
|
+#else
|
|
+#ifndef isnormal
|
|
+#define isnormal(x) \
|
|
+ ((sizeof (x) == sizeof (float)) ? __isnormalf(x) \
|
|
+ : (sizeof (x) == sizeof (double)) ? __isnormal(x) \
|
|
+ : __isnormall(x))
|
|
+#endif
|
|
#endif
|
|
|
|
uint32_t helper_compute_fprf (uint64_t arg, uint32_t set_fprf)
|
|
Index: qemu/x86_64.ld
|
|
@@ -2,7 +2,7 @@
|
|
OUTPUT_FORMAT("elf64-x86-64", "elf64-x86-64", "elf64-x86-64")
|
|
OUTPUT_ARCH(i386:x86-64)
|
|
ENTRY(_start)
|
|
-SEARCH_DIR("/lib64"); SEARCH_DIR("/usr/lib64"); SEARCH_DIR("/usr/local/lib64");
|
|
+SEARCH_DIR("/lib"); SEARCH_DIR("/usr/lib"); SEARCH_DIR("/usr/local/lib");
|
|
SECTIONS
|
|
{
|
|
/* Read-only sections, merged into text segment: */
|
|
@@ -59,8 +59,6 @@
|
|
.rodata : { *(.rodata .rodata.* .gnu.linkonce.r.*) }
|
|
.rodata1 : { *(.rodata1) }
|
|
.eh_frame_hdr : { *(.eh_frame_hdr) }
|
|
- .eh_frame : ONLY_IF_RO { KEEP (*(.eh_frame)) }
|
|
- .gcc_except_table : ONLY_IF_RO { *(.gcc_except_table) }
|
|
/* Adjust the address for the data segment. We want to adjust up to
|
|
the same address within the page on the next page up. */
|
|
. = ALIGN (0x100000) - ((0x100000 - .) & (0x100000 - 1)); . = DATA_SEGMENT_ALIGN (0x100000, 0x1000);
|
|
@@ -86,8 +84,8 @@
|
|
.data1 : { *(.data1) }
|
|
.tdata : { *(.tdata .tdata.* .gnu.linkonce.td.*) }
|
|
.tbss : { *(.tbss .tbss.* .gnu.linkonce.tb.*) *(.tcommon) }
|
|
- .eh_frame : ONLY_IF_RW { KEEP (*(.eh_frame)) }
|
|
- .gcc_except_table : ONLY_IF_RW { *(.gcc_except_table) }
|
|
+ .eh_frame : { KEEP (*(.eh_frame)) }
|
|
+ .gcc_except_table : { *(.gcc_except_table) }
|
|
.dynamic : { *(.dynamic) }
|
|
.ctors :
|
|
{
|