ports/net/asterisk16/files/patch-Makefile
Rene Ladan 2a09e5b4da cleanup: remove support for FreeBSD 13.0 which expired today.
- Mk/bsd.port.mk: mark 13.0 as unsupported
- Tools/scripts/portsearch: Drop support for FreeBSD <= 4
- archivers/zstd: revert "Fix build on FreeBSD 13.0"
- deskutils/xdg-desktop-portal: remove check for 13.0
- devel/libpeas: remove outdated comment
- editors/imhex: remove compatibility for 13.0
- editors/libreoffice: remove compatibility for 13.0
- editors/openoffice-4: remove compatibility for 13.0
- editors/openoffice-devel: remove compatibility for 13.0
- emulators/linux_base-c7: remove compatiblity for 13.0
- graphics/drm-kmod: remove detection for 13.0
- graphics/gpu-firmware-amd-kmod: do not check 13.0 anymore
- graphics/linux-c7-libdrm: remove support for 13.0
- math/igraph: remove support for 13.0
- net/asterisk16: drop support for ancient FreeBSD versions
- net/asterisk18: drop support for ancient FreeBSD versions
- security/openssl*: drop now obsolete patches
- sysutils/bhyve+: drop support for FreeBSD 13.0
- sysutils/ebsnvme-id: drop support for FreeBSD 13.0
- sysutils/openzfs: remove detection of FreeBSD 13.0
- sysutils/openzfs-kmod: drop detection of FreeBSD 13.0
- www/firefox: generalize pkg-message a bit regarding hgame(4)
- x11/xorg-cf-files: remove support for FreeBSD < 6 (yes, pre-2008)

While here, regenerate patches for:
- x11/xorg-cf-files
- net/asterisk16
- net/asterisk18

While here, remove a stale $Id$ from Tools/scripts/portsearch

Differential Revision: https://reviews.freebsd.org/D36233

Reviewed by:	office (fluffy), x11 (manu), arrowd, brnrd, cperciva, freqlabs, imp, jbeich, madpilot, nobutaka
2022-09-01 15:52:16 +02:00

126 lines
4.8 KiB
Text

--- Makefile.orig 2022-08-18 15:13:55 UTC
+++ Makefile
@@ -144,7 +144,7 @@ ASTTOPDIR:=$(subst $(space),\$(space),$(CURDIR))
OVERWRITE=y
# Include debug and macro symbols in the executables (-g) and profiling info (-pg)
-DEBUG=-g3
+#DEBUG=-g3
# Asterisk.conf is located in ASTETCDIR or by using the -C flag
# when starting Asterisk
@@ -168,7 +168,7 @@ LINKER_SYMBOL_PREFIX=
#_ASTCFLAGS+=-DOLD_DSP_ROUTINES
# Default install directory for DAHDI hooks.
-DAHDI_UDEV_HOOK_DIR = /usr/share/dahdi/span_config.d
+#DAHDI_UDEV_HOOK_DIR = /usr/share/dahdi/span_config.d
# If the file .asterisk.makeopts is present in your home directory, you can
# include all of your favorite menuselect options so that every time you download
@@ -226,12 +226,6 @@ else ifneq ($(findstring BSD,$(OSARCH)),)
_ASTCFLAGS+=-isystem /usr/local/include
endif
-ifeq ($(OSARCH),FreeBSD)
- # -V is understood by BSD Make, not by GNU make.
- BSDVERSION=$(shell make -V OSVERSION -f /usr/share/mk/bsd.port.subdir.mk)
- _ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
-endif
-
ifeq ($(OSARCH),NetBSD)
_ASTCFLAGS+=-pthread -D__LIBPTHREAD_SOURCE__ -I/usr/pkg/include
endif
@@ -475,8 +469,12 @@ endif
$(INSTALL) -m 644 $$n "$(DESTDIR)$(ASTDATADIR)/static-http/docs" ; \
done \
fi
+ if [ ! -d $(DESTDIR)$(DOCSDIR)/images ]; then \
+ $(MKDIR) $(DESTDIR)$(DOCSDIR)/images; \
+ fi
+
for x in images/*.jpg; do \
- $(INSTALL) -m 644 $$x "$(DESTDIR)$(ASTDATADIR)/images" ; \
+ $(INSTALL) -m 644 $$x "$(DESTDIR)$(DOCSDIR)/images" ; \
done
$(MAKE) -C sounds install
find rest-api -name "*.json" | while read x; do \
@@ -545,7 +543,7 @@ INSTALLDIRS="$(ASTLIBDIR)" "$(ASTMODDIR)" "$(ASTSBINDI
"$(ASTDATADIR)/firmware/iax" "$(ASTDATADIR)/images" "$(ASTDATADIR)/keys" \
"$(ASTDATADIR)/phoneprov" "$(ASTDATADIR)/rest-api" "$(ASTDATADIR)/static-http" \
"$(ASTDATADIR)/sounds" "$(ASTDATADIR)/moh" "$(ASTMANDIR)/man8" "$(AGI_DIR)" "$(ASTDBDIR)" \
- "$(ASTDATADIR)/third-party" "${ASTDATADIR}/keys/stir_shaken"
+ "$(ASTDATADIR)/third-party" "${ASTDATADIR}/keys/stir_shaken" "$(ASTSPOOLDIR)/outgoing"
installdirs:
@for i in $(INSTALLDIRS); do \
@@ -578,10 +576,10 @@ endif
if [ -f contrib/firmware/iax/iaxy.bin ] ; then \
$(INSTALL) -m 644 contrib/firmware/iax/iaxy.bin "$(DESTDIR)$(ASTDATADIR)/firmware/iax/iaxy.bin"; \
fi
-ifeq ($(HAVE_DAHDI),1)
- $(INSTALL) -d $(DESTDIR)/$(DAHDI_UDEV_HOOK_DIR)
- $(INSTALL) -m 644 contrib/scripts/dahdi_span_config_hook $(DESTDIR)$(DAHDI_UDEV_HOOK_DIR)/40-asterisk
-endif
+#ifeq ($(HAVE_DAHDI),1)
+# $(INSTALL) -d $(DESTDIR)/$(DAHDI_UDEV_HOOK_DIR)
+# $(INSTALL) -m 644 contrib/scripts/dahdi_span_config_hook $(DESTDIR)$(DAHDI_UDEV_HOOK_DIR)/40-asterisk
+#endif
$(SUBDIRS_INSTALL):
+@DESTDIR="$(DESTDIR)" ASTSBINDIR="$(ASTSBINDIR)" ASTDATADIR="$(ASTDATADIR)" $(SUBMAKE) -C $(@:-install=) install
@@ -706,7 +704,7 @@ ifeq ($(ASTERISKVERSION),UNKNOWN__git_check_fail)
endif
-install: badshell versioncheck bininstall datafiles
+install: badshell versioncheck bininstall datafiles samples
@if [ -x /usr/sbin/asterisk-post-install ]; then \
/usr/sbin/asterisk-post-install "$(DESTDIR)" . ; \
fi
@@ -751,23 +749,10 @@ upgrade: bininstall
# (2) the extension to strip off
define INSTALL_CONFIGS
@for x in $(1)/*$(2); do \
- dst="$(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x $(2)`"; \
- if [ -f "$${dst}" ]; then \
- if [ "$(OVERWRITE)" = "y" ]; then \
- if cmp -s "$${dst}" "$$x" ; then \
- echo "Config file $$x is unchanged"; \
- continue; \
- fi ; \
- mv -f "$${dst}" "$${dst}.old" ; \
- else \
- echo "Skipping config file $$x"; \
- continue; \
- fi ;\
- fi ; \
echo "Installing file $$x"; \
- $(INSTALL) -m 644 "$$x" "$${dst}" ;\
+ $(INSTALL) -m 644 $$x $(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x .sample`.sample ; \
done ; \
- if [ "$(OVERWRITE)" = "y" ]; then \
+ if true; then \
echo "Updating asterisk.conf" ; \
sed -e 's|^astcachedir.*$$|astcachedir => $(ASTCACHEDIR)|' \
-e 's|^astetcdir.*$$|astetcdir => $(ASTETCDIR)|' \
@@ -781,8 +766,8 @@ define INSTALL_CONFIGS
-e 's|^astrundir.*$$|astrundir => $(ASTVARRUNDIR)|' \
-e 's|^astlogdir.*$$|astlogdir => $(ASTLOGDIR)|' \
-e 's|^astsbindir.*$$|astsbindir => $(ASTSBINDIR)|' \
- "$(DESTDIR)$(ASTCONFPATH)" > "$(DESTDIR)$(ASTCONFPATH).tmp" ; \
- $(INSTALL) -m 644 "$(DESTDIR)$(ASTCONFPATH).tmp" "$(DESTDIR)$(ASTCONFPATH)" ; \
+ "$(DESTDIR)$(ASTCONFPATH).sample" > "$(DESTDIR)$(ASTCONFPATH).tmp" ; \
+ $(INSTALL) -m 644 "$(DESTDIR)$(ASTCONFPATH).tmp" "$(DESTDIR)$(ASTCONFPATH).sample" ; \
rm -f "$(DESTDIR)$(ASTCONFPATH).tmp" ; \
fi
endef
@@ -816,7 +801,7 @@ adsi:
else \
echo "Installing $$x" ; \
fi ; \
- $(INSTALL) -m 644 "$$x" "$(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x`" ; \
+ $(INSTALL) -m 644 $$x $(DESTDIR)$(ASTETCDIR)/`$(BASENAME) $$x`.sample ; \
done
samples: adsi