ports/emulators/qemu/files/patch-bg
Juergen Lock 332215d971 update qemu to 20061225 snapshot:
- Enable TCP_NODELAY, by Daniel Jacobowitz. [speeding up slirp]
- Run monitor over unix domain sockets, by Anthony Liguori.
- Unix domain socket support for VNC, by Anthony Liguori.
- Daemonize option, by Anthony Liguori.
- SCSI emulation improvements, by Chuck Brazie.
[adding scsi disk/cdrom emulation to i386/amd64 guests using new -disk
syntax - quoting /usr/local/share/doc/qemu/qemu-doc.html:

 "-disk scsi,img=file[,sdx=a..g][,type=disk|cdrom][,id=n]"

    Use file as the SCSI disk/CD-ROM image. The defaults are: sdx=a,type=
    disk,id='auto assign'

doing a quick test with a FreeBSD guest I was able to mount and look at
a ufs partition; doesn't seem to quite work with (some?) linux guests
yet tho, will post about this on the qemu list...]
- and a few bug fixes.

Approved by:	miwi (mentor)
2006-12-25 19:49:52 +00:00

24 lines
621 B
Text

Index: qemu/Makefile.target
@@ -179,7 +179,7 @@
#########################################################
-DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+DEFINES+=-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\"
LIBS+=-lm
ifndef CONFIG_USER_ONLY
LIBS+=-lz
Index: qemu/vl.c
@@ -89,10 +89,12 @@
#include "exec-all.h"
#define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
+#ifndef SMBD_COMMAND
#ifdef __sun__
#define SMBD_COMMAND "/usr/sfw/sbin/smbd"
#else
#define SMBD_COMMAND "/usr/sbin/smbd"
+#endif
#endif
//#define DEBUG_UNUSED_IOPORT