mirror of
https://git.freebsd.org/ports.git
synced 2025-05-15 16:51:52 -04:00
- build with OpenSSL 1.1 - broken multipart/form-data (CVE-2018-16789) - Interpret aixterm high-intensity color escape codes All these patches came from the project pull requests list. Reported by: pkg-fallout Security: CVE-2018-16789
20 lines
1,022 B
Text
20 lines
1,022 B
Text
--- configure.ac.orig 2016-11-09 19:40:33 UTC
|
|
+++ configure.ac
|
|
@@ -138,6 +138,17 @@ AC_ARG_ENABLE(runtime-loading,
|
|
these libraries into the binary, thus making them a
|
|
hard dependency, then disable runtime-loading.])
|
|
|
|
+dnl This changes the order of the top ciphersuites
|
|
+AC_ARG_ENABLE(prefer-chacha,
|
|
+ [ --enable-prefer-chacha Prefer ChaCha20-Poly1305 ciphersuites over
|
|
+ AES256-GCM. For processors without AES-NI or
|
|
+ similar capabilities, ChaCha20-Poly1305 is 3 times
|
|
+ faster than AES, with an equivalent strength.])
|
|
+if test "x$enable_prefer_chacha" == xyes; then
|
|
+ AC_DEFINE(SHELLINABOX_USE_CHACHA_FIRST, 1,
|
|
+ Set if you want to prefer Chacha20-Poly1305 over AES-GCM)
|
|
+fi
|
|
+
|
|
dnl This is feature is not suported in some standard C libs. So users can use
|
|
dnl this switch to avoid compile and runtime problems. Note that utmp must
|
|
dnl disabled on systems with musl libc.
|