ports/multimedia/gstreamer1-plugins-rust/files/patch-gst-1.16
Jan Beich 6e34b28af5 multimedia/gstreamer1-plugins-rust: add new port
Repository containing various GStreamer plugins and elements written
in the Rust programming language:

* generic
  - file: A Rust implementation of the standard filesrc and filesink
    elements

  - sodium: Elements to perform encryption and decryption using
    libsodium.

  - threadshare: Some popular threaded elements reimplemented using common
    thread-sharing infrastructure.

* net
  - reqwest: An HTTP source element based on the reqwest library.

  - rusoto: A source and sink plugin to talk to the Amazon S3 object
    storage system using the Rusoto library.

* audio
  - audiofx: Plugins to apply audio effects to a stream (such as
    adding echo/reverb, removing noise or normalization).

  - claxon: A FLAC decoder based on the Claxon library.

  - csound: A plugin to implement audio effects using the Csound
    library.

  - lewton: A Vorbis decoder based on the lewton library.

* video
  - cdg: A parser and renderer for CD+G karaoke data.

  - closedcaption: Plugins to deal with several closed caption formats
    (MCC, SCC, EIA-608/CEA-608 and timed text).

  - dav1d: AV1 decoder based on the dav1d library.

  - flavors: FLV demuxer based on the flavors library.

  - gif: A GIF encoder based on the gif library.

  - rav1e: AV1 encoder based on the rav1e library.

* utils
  - fallbackswitch: Aggregator element that allows falling back to a
    different sink pad after a timeout.

  - togglerecord: Element to enable starting and stopping multiple
    streams together.

https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs
2021-08-15 14:45:11 +00:00

38 lines
1.5 KiB
Text

Drop after multimedia/gstreamer1-plugins is updated to 1.18 or later
Package dependency requirement 'gstreamer-1.0 >= 1.18' could not be satisfied.
Package 'gstreamer-1.0' has version '1.16.2', required version is '>= 1.18'
error[E0599]: no method named `pull_until_eos` found for struct `Harness` in the current scope
--> audio/audiofx/tests/ebur128level.rs:113:33
|
113 | while let Some(_buffer) = h.pull_until_eos().unwrap() {
| ^^^^^^^^^^^^^^ method not found in `Harness`
--- audio/audiofx/Cargo.toml
+++ audio/audiofx/Cargo.toml 2021-08-15 06:32:37.895468529 +0000
@@ -25,7 +25,7 @@ crate-type = ["cdylib", "rlib"]
path = "src/lib.rs"
[dev-dependencies]
-gst-check = { package = "gstreamer-check", version = "0.17", features = ["v1_18"] }
+gst-check = { package = "gstreamer-check", version = "0.17", features = ["v1_16"] }
gst-app = { package = "gstreamer-app", version = "0.17" }
[build-dependencies]
--- audio/audiofx/tests/ebur128level.rs.orig 2021-08-05 15:13:43 UTC
+++ audio/audiofx/tests/ebur128level.rs
@@ -110,7 +110,13 @@ fn run_test(layout: gst_audio::AudioLayout, format: gs
// Pull all buffers until EOS
let mut num_buffers = 0;
+ #[cfg(feature = "v1_18")]
while let Some(_buffer) = h.pull_until_eos().unwrap() {
+ num_buffers += 1;
+ }
+ #[cfg(not(feature = "v1_18"))]
+ for _ in 0..5 {
+ h.pull().unwrap();
num_buffers += 1;
}
assert_eq!(num_buffers, 5);