ports/lang/rexx-regutil/files/patch-rxproto.h
Kurt Jaeger 8489b4ac92 lang/rexx-regutil: several patches
- additional MASTER_SITE (there was only one)
- tidied Makefile considerably
- fixed failure to build under different PREFIX
- added DOC option
- added EXAMPLES option, and now can have examples (there were none before)
- eliminated numerous compilation warnings
- REMOVED pkg-plist (only two files in it)
- REMOVED pkg-message (now redundant)
- ADDED new patches in files/

PR:		209379
Submitted by:	bob@eager.cx (maintainer)
2016-05-08 17:50:04 +00:00

11 lines
496 B
C

--- rxproto.h.orig 2003-05-23 11:05:50 UTC
+++ rxproto.h
@@ -53,7 +53,7 @@
* to something else, and a pointer to the result string.
* It returns 0 for success, and some other value for failure */
-#define rxfunc(x) APIRET APIENTRY x(PUCHAR fname, ULONG argc, PRXSTRING argv, PSZ pSomething, PRXSTRING result)
+#define rxfunc(x) APIRET APIENTRY x(PCSZ fname, ULONG argc, PRXSTRING argv, PCSZ pSomething, PRXSTRING result)
/* return codes. 22 is rc for invalid call */
#define NOMEMORY 5