ports/lang/julia/files/patch-Makefile
Eric Reardon 6b461fe119 lang/julia: Bring back the port.
Reviewed By: thierry, tcberner, Greg V <greg@unrelenting.technology>, Filipe da Silva Santos <contact@shiori.com.br>, arrowd

Differential Revision: https://reviews.freebsd.org/D33121
2021-12-29 14:39:58 +03:00

63 lines
2.7 KiB
Text

--- Makefile.orig 2021-11-30 12:13:06 UTC
+++ Makefile
@@ -226,7 +226,7 @@ define stringreplace
endef
-install: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html
+install: $(build_depsbindir)/stringreplace
ifeq ($(BUNDLE_DEBUG_LIBS),1)
@$(MAKE) $(QUIET_MAKE) all
else
@@ -314,8 +314,6 @@ endif
cp -R -L $(JULIAHOME)/base/* $(DESTDIR)$(datarootdir)/julia/base
cp -R -L $(JULIAHOME)/test/* $(DESTDIR)$(datarootdir)/julia/test
cp -R -L $(build_datarootdir)/julia/* $(DESTDIR)$(datarootdir)/julia
- # Copy documentation
- cp -R -L $(BUILDROOT)/doc/_build/html $(DESTDIR)$(docdir)/
# Remove various files which should not be installed
-rm -f $(DESTDIR)$(datarootdir)/julia/base/version_git.sh
-rm -f $(DESTDIR)$(datarootdir)/julia/test/Makefile
@@ -325,12 +323,6 @@ endif
-rm -f $(DESTDIR)$(datarootdir)/julia/stdlib/$(VERSDIR)/*/build-checked
# Copy in beautiful new man page
$(INSTALL_F) $(build_man1dir)/julia.1 $(DESTDIR)$(man1dir)/
- # Copy .desktop file
- mkdir -p $(DESTDIR)$(datarootdir)/applications/
- $(INSTALL_F) $(JULIAHOME)/contrib/julia.desktop $(DESTDIR)$(datarootdir)/applications/
- # Install appdata file
- mkdir -p $(DESTDIR)$(datarootdir)/appdata/
- $(INSTALL_F) $(JULIAHOME)/contrib/julia.appdata.xml $(DESTDIR)$(datarootdir)/appdata/
# Update RPATH entries and JL_SYSTEM_IMAGE_PATH if $(private_libdir_rel) != $(build_private_libdir_rel)
ifneq ($(private_libdir_rel),$(build_private_libdir_rel))
@@ -384,26 +376,15 @@ ifeq ($(BUNDLE_DEBUG_LIBS),1)
endif
endif
- # On FreeBSD, remove the build's libdir from each library's RPATH
-ifeq ($(OS),FreeBSD)
- $(JULIAHOME)/contrib/fixup-rpath.sh "$(PATCHELF)" $(DESTDIR)$(libdir) $(build_libdir)
- $(JULIAHOME)/contrib/fixup-rpath.sh "$(PATCHELF)" $(DESTDIR)$(private_libdir) $(build_libdir)
- $(JULIAHOME)/contrib/fixup-rpath.sh "$(PATCHELF)" $(DESTDIR)$(bindir) $(build_libdir)
- # Set libgfortran's RPATH to ORIGIN instead of GCCPATH. It's only libgfortran that
- # needs to be fixed here, as libgcc_s and libquadmath don't have RPATHs set. If we
- # don't set libgfortran's RPATH, it won't be able to find its friends on systems
- # that don't have the exact GCC port installed used for the build.
- for lib in $(DESTDIR)$(private_libdir)/libgfortran*$(SHLIB_EXT)*; do \
- $(PATCHELF) --set-rpath '$$ORIGIN' $$lib; \
- done
-endif
-
mkdir -p $(DESTDIR)$(sysconfdir)
cp -R $(build_sysconfdir)/julia $(DESTDIR)$(sysconfdir)/
ifeq ($(DARWIN_FRAMEWORK),1)
$(MAKE) -C $(JULIAHOME)/contrib/mac/framework frameworknoinstall
endif
+install-docs:
+ #Copy documentation
+ cp -R -L $(BUILDROOT)/doc/_build/html $(DESTDIR)$(docdir)/
distclean:
-rm -fr $(BUILDROOT)/julia-*.tar.gz $(BUILDROOT)/julia*.exe $(BUILDROOT)/julia-$(JULIA_COMMIT)