ports/dns/py-publicsuffix2/files/patch-setup.py
Sunpoet Po-Chuan Hsieh b244f2560a Add py-publicsuffix2 2.20191221
This module allows you to get the public suffix of a domain name using the
Public Suffix List from http://publicsuffix.org

A public suffix is one under which Internet users can directly register names.
Some examples of public suffixes are .com, .co.uk and pvt.k12.wy.us. Accurately
knowing the public suffix of a domain is useful when handling web browser
cookies, highlighting the most important part of a domain name in a user
interface or sorting URLs by web site

WWW: https://github.com/nexb/python-publicsuffix2

- While I'm here, patch setup.py to avoid unnecessary py-requests dependency and network connection during build

PR:		243846
Submitted by:	<ml@netfence.it>
2020-02-04 17:58:34 +00:00

18 lines
569 B
Python

--- setup.py.orig 2019-12-21 11:28:25 UTC
+++ setup.py
@@ -96,9 +96,6 @@ setup(
py_modules=[splitext(basename(path))[0] for path in glob('src/*.py')],
include_package_data=True,
zip_safe=False,
- setup_requires = [
- 'requests >= 2.7.0',
- ],
classifiers=[
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
@@ -113,5 +110,4 @@ setup(
keywords=[
'domain', 'public suffix', 'suffix', 'dns', 'tld', 'sld', 'psl', 'idna',
],
- cmdclass={'update_psl': UpdatePslCommand},
)