mirror of
https://git.freebsd.org/ports.git
synced 2025-05-03 12:06:39 -04:00
Seems like the compiler got a whole lot stricter with this release. The biggest fix was changing the thread ID from unsigned long to pthread_t, which will probably break compilation on Win32. While we are at it, replace static uses of REINPLACE_CMD with patch files as per policy. This change is responsible for most of the newly added patches. The wzdftpd build scripts want to install plugins into ${PREFIX}/share when they belong into ${PREFIX}/lib. Instead of patching this in each Makefile.am, set --datadir=${PREFIX}/lib and work around the one file for which this is wrong. Approved by: eduardo (mentor) Differential Revision: https://reviews.freebsd.org/D38523
14 lines
558 B
C
14 lines
558 B
C
--- wzdftpd/wzd_opts.h.orig 2023-02-11 11:32:00 UTC
|
|
+++ wzdftpd/wzd_opts.h
|
|
@@ -24,11 +24,7 @@ struct option
|
|
#define optional_argument 2
|
|
|
|
#if __STDC__
|
|
-#if defined(__GNU_LIBRARY__)
|
|
extern int getopt (int argc, char *const *argv, const char *shortopts);
|
|
-#else /* not __GNU_LIBRARY__ */
|
|
-extern int getopt ();
|
|
-#endif /* not __GNU_LIBRARY__ */
|
|
extern int getopt_long (int argc, char *const *argv, const char
|
|
*shortopts, const struct option *longopts, int
|
|
*longind); extern int getopt_long_only (int argc, char *const *argv,
|