ports/security/wazuh-manager/files/patch-framework_Makefile
Jose Alonso Cardenas Marquez d7fcd1c31b security/wazuh-manager: New port: Security tool to monitor and check logs and intrusions (server)
Wazuh is a free and open source platform used for threat prevention, detection,
and response. It is capable of protecting workloads across on-premises,
virtualized, containerized, and cloud-based environments.

Wazuh solution consists of an endpoint security agent, deployed to the
monitored systems, and a management server, which collects and analyzes data
gathered by the agents. Besides, Wazuh has been fully integrated with the
Elastic Stack, providing a search engine and data visualization tool that
allows users to navigate through their security alerts.

WWW: https://wazuh.com/
2022-07-31 15:20:14 -05:00

21 lines
674 B
Text

--- framework/Makefile 2022-07-26 15:50:26.898033000 -0500
+++ framework/Makefile 2022-07-26 15:51:11.464092000 -0500
@@ -7,13 +7,13 @@
WAZUH_GROUP = wazuh
INSTALLDIR ?= /var/ossec
-CC = gcc
-CFLAGS = -pipe -Wall -Wextra
+CC ?= gcc
+CFLAGS ?= -pipe -Wall -Wextra
THREAD_FLAGS = -pthread
RM_FILE = rm -f
-INSTALL_DIR = install -o root -g ${WAZUH_GROUP} -m 0750 -d
-INSTALL_EXEC = install -o root -g ${WAZUH_GROUP} -m 0750
-INSTALL_FILE = install -o root -g ${WAZUH_GROUP} -m 0640
+INSTALL_DIR = install -m 0750 -d
+INSTALL_EXEC = install -m 0750
+INSTALL_FILE = install -m 0640
ifdef DEBUG
CFLAGS+=-g -I ../src