ports/security/gpgme/files/patch-lang_python_Makefile.in
2018-01-26 04:02:18 +00:00

29 lines
982 B
Text

First hunk:
The swig executable from devel/swig30 is named 'swig3.0' and the build system
only looks for an executable named 'swig':
unable to execute 'swig': No such file or directory
Second hunk:
Fix staging and build the *.pyc and *.pyo files
--- lang/python/Makefile.in.orig 2017-12-12 11:56:08 UTC
+++ lang/python/Makefile.in
@@ -740,7 +740,7 @@ all-local: copystamp
CFLAGS="$(CFLAGS)" \
srcdir="$(srcdir)" \
top_builddir="$(top_builddir)" \
- $$PYTHON setup.py build --verbose --build-base="$$(basename "$${PYTHON}")-gpg" ; \
+ $$PYTHON setup.py build --verbose --build-base="$$(basename "$${PYTHON}")-gpg" build_ext --swig=$(SWIG) ; \
done
python$(PYTHON_VERSION)-gpg/dist/gpg-$(VERSION).tar.gz.asc: copystamp
@@ -782,7 +782,8 @@ install-exec-local:
build \
--build-base="$$(basename "$${PYTHON}")-gpg" \
install \
- --prefix "$(DESTDIR)$(prefix)" \
+ -c -O1 --prefix=$(prefix) \
+ --root=$(DESTDIR) \
--verbose ; \
done