mirror of
https://git.freebsd.org/ports.git
synced 2025-05-01 11:06:39 -04:00
The filesystems category houses file systems and file system utilities. It is added mainly to turn the sysutils/fusefs-* pseudo-category into a proper one, but is also useful for the sundry of other file systems related ports found in the tree. Ports that seem like they belong there are moved to the new category. Two ports, sysutils/fusefs-funionfs and sysutils/fusefs-fusepak are not moved as they currently don't fetch and don't have TIMESTAMP set in their distinfo, but that is required to be able to push a rename of the port by the pre-receive hook. Approved by: portmgr (rene) Reviewed by: mat Pull Request: https://github.com/freebsd/freebsd-ports/pull/302 PR: 281988
23 lines
1.1 KiB
Rust
23 lines
1.1 KiB
Rust
libc crate defines ENOTSUP as an alias for EOPNOTSUPP. nix crate
|
|
does not re-export EOPNOTSUPP on FreeBSD but ENOTSUP is available.
|
|
|
|
--- src/nodes/mod.rs.orig 2020-04-20 18:46:46 UTC
|
|
+++ src/nodes/mod.rs
|
|
@@ -97,7 +97,7 @@ fn setattr_mode(attr: &mut fuse::FileAttr, path: Optio
|
|
if attr.kind == fuse::FileType::Symlink {
|
|
// TODO(jmmv): Should use NoFollowSymlink to support changing the mode of a symlink if
|
|
// requested to do so, but this is not supported on Linux.
|
|
- return Err(nix::Error::from_errno(Errno::EOPNOTSUPP));
|
|
+ return Err(nix::Error::from_errno(Errno::ENOTSUP));
|
|
}
|
|
|
|
let result = try_path(path, |p|
|
|
@@ -144,7 +144,7 @@ fn setattr_times(attr: &mut fuse::FileAttr, path: Opti
|
|
if attr.kind == fuse::FileType::Symlink {
|
|
eprintln!(
|
|
"utimensat not present; ignoring request to change symlink times for {:?}", path);
|
|
- Err(nix::Error::from_errno(Errno::EOPNOTSUPP))
|
|
+ Err(nix::Error::from_errno(Errno::ENOTSUP))
|
|
} else {
|
|
try_path(path, |p| sys::stat::utimes(p, &atime, &mtime))
|
|
}
|