ports/www/py-pywikibot/files/patch-setup.py
Yuri Victorovich bfd8c9b916 www/py-pywikibot: update 8.6.0 → 9.0.0
Reported by:	portscout
2024-03-08 23:34:15 -08:00

21 lines
694 B
Python

--- setup.py.orig 2024-03-09 06:20:55 UTC
+++ setup.py
@@ -160,12 +160,12 @@ def get_validated_version(name: str) -> str: # pragma
from packaging.version import InvalidVersion, Version
- try:
- tags = run(['git', 'tag'], check=True, stdout=PIPE,
- text=True).stdout.splitlines()
- except Exception as e:
- print(e)
- sys.exit('Creating source distribution canceled.')
+ #try:
+ # tags = run(['git', 'tag'], check=True, stdout=PIPE,
+ # text=True).stdout.splitlines()
+ #except Exception as e:
+ # print(e)
+ # sys.exit('Creating source distribution canceled.')
last_tag = None
if tags: