ports/databases/sqlrelay/files/patch-etc_Makefile
Kurt Jaeger 96f080dbe5 devel/rudiments: update 1.0.2 -> 1.0.4
databases/sqlrelay: update 1.0.0 -> 1.0.1

rudiments:
- added support for EOT to codetree
- added loop-avoidance to xmldomevents class
- added alias support to codetree class
- replaced readline with libedit
- included implementation of history_truncate_file for versions of
  libedit that don't provide it
- added --disable-wall and --disable-werror configure options

sqlrelay:
- updated sqlr-bench to create "db"-bench.png
- added edoc-generated API docs for the Erlang API
- updated some module-load error verbage
- added initial support for loading Oracle, SAP/Sybase, DB2, and Informix
  libraries on-demand at runtime
- overhauled spec file
- fixed PDO driver for PHP 7 on 32-bit platforms
- added permissions to all open() with O_CREAT calls
- added --with-fortify configure option
- fixed a segfault on ctrl-D in sqlrsh
- fixed uncoordinated access to shared debugstr among listener threads
  by using local instances instead
- added ping-loop to router connection module's logIn() method to manage
  cases where routed-to instances are started after the router
- moved .../var/sqlrelay/tmp/*/* to .../var/run/sqlrelay
- added .sock extension to sockets, .ipc extension to ipc key files,
  .pid extension to pid files, and .up extension to files which
  indicate that the db is up
- changed mode of listener-connection sockets to 700 from 711
- moved .../var/sqlrelay/log to .../var/log/sqlrelay
- moved .../var/sqlrelay/cache to .../var/cache/sqlrelay
- libmysql*sqlrelay.so and libpqsqlrelay.so are no longer installed
- replaced sockseq-generated unix socket with pid-based unix socket
- updated ruby api to support unification of Fixnum and Bignum classes
  into Integer class
- added --with-abs-max-connections configure script parameter
- increased default absolute max connections to 4096 (from 512)
- updated "can't open ... file" errors to mention user/group
- added SQLR_MYSQL_MAP_DATE_TO_DATETIME option to mysql drop-in
  replacement library
- fixed normalize translation not to remove spaces before unary - and !
- updated sqlrsh to set error code correctly and write errors to stderr
- sqlr-cachemanager is no longer enabled at boot by default
- fixed another subtle bug in the ODBC driver that caused the first row
  to be duplicated if columns were not bound
- added --disable-wall and --disable-werror configure options
2017-03-26 09:49:52 +00:00

22 lines
821 B
Text

--- etc/Makefile.orig 2016-01-28 19:28:21 UTC
+++ etc/Makefile
@@ -3,12 +3,13 @@ top_builddir = ..
include ../config.mk
install:
- $(MKINSTALLDIRS) $(sysconfdir)/$(SQLRELAY).conf.d
- $(CP) sqlrelay.xsd $(sysconfdir)/$(SQLRELAY).xsd
- $(CHMOD) 644 $(sysconfdir)/$(SQLRELAY).xsd
- $(MKINSTALLDIRS) $(EXAMPLEDIR)
- $(CP) sqlrelay.conf $(EXAMPLEDIR)/$(SQLRELAY).conf
- $(CHMOD) 644 $(EXAMPLEDIR)/$(SQLRELAY).conf
+ $(MKINSTALLDIRS) $(sysconfdir)/$(SQLRELAY)
+ $(CP) sqlrelay.conf $(sysconfdir)/$(SQLRELAY)/conf.sample
+ $(CHMOD) 644 $(sysconfdir)/$(SQLRELAY)/conf.sample
+ $(CP) sqlrelay.xsd $(sysconfdir)/$(SQLRELAY)/
+ $(CHMOD) 644 $(sysconfdir)/$(SQLRELAY)/sqlrelay.xsd
+ $(CP) sqlrelay.conf $(EXAMPLEDIR)/sqlrelay.conf
+ $(CHMOD) 644 $(EXAMPLEDIR)/sqlrelay.conf
uninstall:
$(RM) $(EXAMPLEDIR)/$(SQLRELAY).conf \