ports/databases/mysql80-client/files/patch-include_CMakeLists.txt
Mahdi Mokhtari 40a0e27769 databases/mysql80-{server, client}: Update port to the latest release 8.0.2
Changes happened into format of --version which caused r450384

Reviewed by:	mat (mentor)
Approved by:	mat (mentor)
Sponsored by:	Netzkommune GmbH
Differential Revision:	https://reviews.freebsd.org/D12579
2017-10-06 15:44:18 +00:00

182 lines
3.9 KiB
Text

--- include/CMakeLists.txt.orig 2017-09-21 15:51:58 UTC
+++ include/CMakeLists.txt
@@ -30,11 +30,179 @@ SET(HEADERS
${CMAKE_CURRENT_BINARY_DIR}/mysql_version.h
${CMAKE_CURRENT_BINARY_DIR}/mysqld_error.h
../libbinlogevents/export/binary_log_types.h
+ base64.h
+ big_endian.h
+ byte_order_generic.h
+ byte_order_generic_x86.h
+ c_string_less.h
+ crypt_genhash_impl.h
+ decimal.h
+ depth_first_search.h
+ dur_prop.h
+ errmsg.h
+ ft_global.h
+ hash.h
+ heap.h
+ keycache.h
+ lex_string.h
+ lf.h
+ little_endian.h
+ m_ctype.h
+ m_string.h
+ map_helpers.h
+ mem_root_fwd.h
+ mf_wcomp.h
+ mutex_lock.h
+ my_aes.h
+ my_alloc.h
+ my_atomic.h
+ my_base.h
+ my_bit.h
+ my_bitmap.h
+ my_byteorder.h
+ my_check_opt.h
+ my_command.h
+ my_compare.h
+ my_compare.h.orig
+ my_compiler.h
+ my_dbug.h
+ my_default.h
+ my_dir.h
+ my_double2ulonglong.h
+ my_getopt.h
+ my_hash_combine.h
+ my_icp.h
+ my_inttypes.h
+ my_io.h
+ my_list.h
+ my_loglevel.h
+ my_macros.h
+ my_md5.h
+ my_md5_size.h
+ my_murmur3.h
+ my_pointer_arithmetic.h
+ my_psi_config.h
+ my_rapidjson_size_t.h
+ my_rdtsc.h
+ my_rnd.h
+ my_sharedlib.h
+ my_shm_defaults.h
+ my_sqlcommand.h
+ my_stacktrace.h
+ my_sys.h
+ my_systime.h
+ my_table_map.h
+ my_thread.h
+ my_thread_local.h
+ my_thread_os_id.h
+ my_time.h
+ my_timer.h
+ my_tree.h
+ my_uctype.h
+ my_user.h
+ my_xml.h
+ myisam.h
+ myisammrg.h
+ myisampack.h
+ mysql.h
+ mysql.h.pp
+ mysql_com.h
+ mysql_com_server.h
+ mysql_time.h
+ mysql_version.h.in
+ mysys_err.h
+ nullable.h
+ password.h
+ pfs_cond_provider.h
+ pfs_error_provider.h
+ pfs_file_provider.h
+ pfs_idle_provider.h
+ pfs_memory_provider.h
+ pfs_metadata_provider.h
+ pfs_mutex_provider.h
+ pfs_rwlock_provider.h
+ pfs_socket_provider.h
+ pfs_stage_provider.h
+ pfs_statement_provider.h
+ pfs_table_provider.h
+ pfs_thread_provider.h
+ pfs_transaction_provider.h
+ prealloced_array.h
+ print_version.h
+ priority_queue.h
+ rwlock_scoped_lock.h
+ scope_guard.h
+ service_versions.h
+ sha1.h
+ sha2.h
+ sql_chars.h
+ sql_common.h
+ sql_string.h
+ sslopt-case.h
+ sslopt-longopts.h
+ sslopt-vars.h
+ str_uca_type.h
+ template_utils.h
+ thr_cond.h
+ thr_lock.h
+ thr_mutex.h
+ thr_rwlock.h
+ typelib.h
+ varlen_sort.h
+ violite.h
+ welcome_copyright_notice.h
)
SET(HEADERS_MYSQL_DIR
mysql/client_plugin.h
mysql/plugin_auth_common.h
mysql/udf_registration_types.h
+ mysql/client_authentication.h
+ mysql/client_plugin.h.pp
+ mysql/com_data.h
+ mysql/get_password.h
+ mysql/group_replication_priv.h
+ mysql/innodb_priv.h
+ mysql/mysql_lex_string.h
+ mysql/plugin.h
+ mysql/plugin_audit.h
+ mysql/plugin_audit.h.pp
+ mysql/plugin_auth.h
+ mysql/plugin_auth.h.pp
+ mysql/plugin_auth_common.h
+ mysql/plugin_ftparser.h
+ mysql/plugin_ftparser.h.pp
+ mysql/plugin_group_replication.h
+ mysql/plugin_keyring.h
+ mysql/plugin_keyring.h.pp
+ mysql/plugin_query_rewrite.h
+ mysql/plugin_trace.h
+ mysql/plugin_validate_password.h
+ mysql/service_command.h
+ mysql/service_locking.h
+ mysql/service_my_plugin_log.h
+ mysql/service_my_snprintf.h
+ mysql/service_mysql_alloc.h
+ mysql/service_mysql_keyring.h
+ mysql/service_mysql_password_policy.h
+ mysql/service_mysql_string.h
+ mysql/service_parser.h
+ mysql/service_plugin_registry.h
+ mysql/service_rpl_transaction_ctx.h
+ mysql/service_rpl_transaction_write_set.h
+ mysql/service_rules_table.h
+ mysql/service_security_context.h
+ mysql/service_srv_session.h
+ mysql/service_srv_session_info.h
+ mysql/service_ssl_wrapper.h
+ mysql/service_thd_alloc.h
+ mysql/service_thd_engine_lock.h
+ mysql/service_thd_wait.h
+ mysql/service_thread_scheduler.h
+ mysql/services.h
+ mysql/services.h.pp
+ mysql/thread_pool_priv.h
+ mysql/thread_type.h
+ mysql/udf_registration_types.h
)
INSTALL(FILES ${HEADERS} DESTINATION ${INSTALL_INCLUDEDIR} COMPONENT Development)