ports/databases/mariadb55-server/files/patch-libmysql_CMakeLists.txt
Bernard Spil e1822696f3 databases/mariadb55-server: Update to 5.5.56
- Bugfix update to 5.5.56
 - Re-roll patches
 - Convert patches to new naming convention
 - Add/move ldconfig config to -server
 - Move client option to -client port
2017-05-04 09:33:18 +00:00

39 lines
1.3 KiB
Text

--- libmysql/CMakeLists.txt.orig 2017-04-30 11:09:29 UTC
+++ libmysql/CMakeLists.txt
@@ -425,7 +425,7 @@ SET(LIBS clientlib dbug strings vio mysy
# Merge several convenience libraries into one big mysqlclient
# and link them together into shared library.
-MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development)
+MERGE_LIBRARIES(mysqlclient STATIC ${LIBS} COMPONENT Development NOINSTALL)
# Visual Studio users need debug static library for debug projects
IF(MSVC)
@@ -433,6 +433,7 @@ IF(MSVC)
INSTALL_DEBUG_TARGET(clientlib DESTINATION ${INSTALL_LIBDIR}/debug)
ENDIF()
+IF(FALSE)
IF(UNIX)
MACRO(GET_VERSIONED_LIBNAME LIBNAME EXTENSION VERSION OUTNAME)
SET(DOT_VERSION ".${VERSION}")
@@ -447,11 +448,13 @@ IF(UNIX)
ENDMACRO()
INSTALL_SYMLINK(${CMAKE_STATIC_LIBRARY_PREFIX}mysqlclient_r.a mysqlclient ${INSTALL_LIBDIR} Development)
ENDIF()
+ENDIF()
IF(NOT DISABLE_SHARED)
MERGE_LIBRARIES(libmysql SHARED ${LIBS}
EXPORTS ${CLIENT_API_FUNCTIONS} ${CLIENT_API_5_1_EXTRA} ${CLIENT_API_5_5_EXTRA}
- COMPONENT SharedLibraries)
+ COMPONENT SharedLibraries NOINSTALL)
+IF(FALSE)
IF(UNIX)
# libtool compatability
IF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD" OR APPLE)
@@ -495,3 +498,4 @@ IF(NOT DISABLE_SHARED)
ENDFOREACH()
ENDIF()
ENDIF()
+ENDIF()