mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
* Use to multimedia/ffmpeg3 for compatibility and stability * Submitter becomes maintainer Changelog: https://www.ppsspp.org/news/release-1.18/ Reset PORTREVISION for slave ports, emulators/libretro-ppsspp and emulators/ppsspp-qt5 PR: 282792
33 lines
1.1 KiB
Text
33 lines
1.1 KiB
Text
EGL hangs on X11 and doesn't build without GLESv2.
|
|
https://github.com/hrydgard/ppsspp/issues/10626
|
|
|
|
--- CMakeLists.txt.orig 2024-11-04 16:16:10 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -79,12 +79,6 @@ endif()
|
|
set(USE_SYSTEM_FFMPEG ON)
|
|
endif()
|
|
|
|
-if(NOT ANDROID AND NOT IOS)
|
|
- if(ARM_DEVICE OR SIMULATOR)
|
|
- set(USING_EGL ON)
|
|
- endif()
|
|
-endif()
|
|
-
|
|
if(${CMAKE_SYSTEM_NAME} MATCHES "Linux" AND NOT USE_LIBNX)
|
|
set(LINUX ON)
|
|
add_definitions(-D__STDC_CONSTANT_MACROS)
|
|
@@ -383,8 +377,12 @@ if(NOT MSVC)
|
|
add_definitions(-DPNG_ARM_NEON_OPT=0)
|
|
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Werror=return-type -Wno-unused-function -Wno-sign-compare -Wno-unused-but-set-variable -Wno-reorder -Wno-unknown-pragmas -Wno-unused-value -Wno-unused-variable")
|
|
- # This one is very useful but has many false positives.
|
|
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-class-memaccess")
|
|
+ if(NOT CLANG)
|
|
+ # This one is very useful but has many false positives.
|
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-class-memaccess")
|
|
+ else()
|
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-deprecated-declarations")
|
|
+ endif()
|
|
|
|
if(ANDROID)
|
|
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++17")
|