mirror of
https://git.freebsd.org/ports.git
synced 2025-04-30 18:46:38 -04:00
It is required by PrusaSlicer 2.7+. This port provides library and binary to work with g-code (read/write/convert) Reported by: Teodor Sigaev <teodorsigaev@gmail.com> Reviewed by: lwhsu (mentor) Sponsored by: Postgres Professional Differential Revision: https://reviews.freebsd.org/D44257
23 lines
987 B
Text
23 lines
987 B
Text
--- deps/CMakeLists.txt.orig 2024-01-22 12:56:01 UTC
|
|
+++ deps/CMakeLists.txt
|
|
@@ -41,16 +41,16 @@ include(${PROJECT_SOURCE_DIR}/../cmake/modules/AddCMak
|
|
|
|
include(${PROJECT_SOURCE_DIR}/../cmake/modules/AddCMakeProject.cmake)
|
|
|
|
-set(supported_packages Boost heatshrink Catch2 ZLIB pybind11)
|
|
+set(supported_packages heatshrink)
|
|
|
|
include(CMakeDependentOption)
|
|
option(${PROJECT_NAME}_SELECT_ALL "Choose all external projects to be selected (create build target for them)." ON)
|
|
option(${PROJECT_NAME}_BUILD_ALL "Choose all external projects to be built." OFF)
|
|
|
|
-find_package(Git REQUIRED)
|
|
-
|
|
+#find_package(Git REQUIRED)
|
|
+#
|
|
# The default command line for patching. Only works for newer
|
|
-set(PATCH_CMD ${GIT_EXECUTABLE} apply --verbose --ignore-space-change --whitespace=fix)
|
|
+#set(PATCH_CMD ${GIT_EXECUTABLE} apply --verbose --ignore-space-change --whitespace=fix)
|
|
|
|
foreach (pkg ${supported_packages})
|
|
option(${PROJECT_NAME}_BUILD_${pkg} "Select package ${pkg} to be built." OFF)
|