ports/graphics/epsonscan2/files/patch-src_Standalone_CMakeLists.txt
J.R. Oldroyd 27cd1370ef graphics/epsonscan2: Unbreak build with boost 1.87
clang does support rvalue references, so remove all use of flag
"BOOST_NO_CXX11_RVALUE_REFERENCES"

PR:	284127
2025-02-14 23:40:35 +03:00

18 lines
586 B
Text

--- src/Standalone/CMakeLists.txt.orig 2024-09-12 07:10:30 UTC
+++ src/Standalone/CMakeLists.txt
@@ -28,8 +28,6 @@ find_package(Qt5Widgets REQUIRED)
find_package(Qt5Gui REQUIRED)
find_package(Qt5Widgets REQUIRED)
-add_definitions(-DBOOST_NO_CXX11_RVALUE_REFERENCES=1)
-
INCLUDE_DIRECTORIES(
../
../../
@@ -167,5 +165,5 @@ QT5_USE_MODULES(es2standalone Widgets)
)
QT5_USE_MODULES(es2standalone Widgets)
-install(TARGETS es2standalone DESTINATION "${EPSON_INSTALL_ROOT}/usr/bin")
+install(TARGETS es2standalone DESTINATION "${EPSON_INSTALL_ROOT}${CMAKE_INSTALL_PREFIX}/bin")