mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
clang does support rvalue references, so remove all use of flag "BOOST_NO_CXX11_RVALUE_REFERENCES" PR: 284127
42 lines
1.1 KiB
Text
42 lines
1.1 KiB
Text
--- src/Controller/CMakeLists.txt.orig 2024-09-12 07:10:30 UTC
|
|
+++ src/Controller/CMakeLists.txt
|
|
@@ -24,8 +24,6 @@ PROJECT(epsonscan2)
|
|
|
|
PROJECT(epsonscan2)
|
|
|
|
-add_definitions(-DBOOST_NO_CXX11_RVALUE_REFERENCES=1)
|
|
-
|
|
INCLUDE_DIRECTORIES(
|
|
../
|
|
./Include
|
|
@@ -171,21 +169,6 @@ ADD_LIBRARY(epsonscan2 SHARED
|
|
../../thirdparty/HaruPDF/hpdf_exdata.c
|
|
../../thirdparty/HaruPDF/hpdf_encoder_utf.c
|
|
|
|
-../../thirdparty/zlib/adler32.c
|
|
-../../thirdparty/zlib/crc32.c
|
|
-../../thirdparty/zlib/gzclose.c
|
|
-../../thirdparty/zlib/gzread.c
|
|
-../../thirdparty/zlib/infback.c
|
|
-../../thirdparty/zlib/inflate.c
|
|
-../../thirdparty/zlib/trees.c
|
|
-../../thirdparty/zlib/zutil.c
|
|
-../../thirdparty/zlib/compress.c
|
|
-../../thirdparty/zlib/deflate.c
|
|
-../../thirdparty/zlib/gzlib.c
|
|
-../../thirdparty/zlib/gzwrite.c
|
|
-../../thirdparty/zlib/inffast.c
|
|
-../../thirdparty/zlib/inftrees.c
|
|
-../../thirdparty/zlib/uncompr.c
|
|
../../thirdparty/sha1/sha1.c
|
|
)
|
|
|
|
@@ -194,7 +177,7 @@ target_link_libraries( epsonscan2
|
|
dl
|
|
commonutility
|
|
${Boost_LIBRARIES}
|
|
- usb-1.0
|
|
+ ${usb_LIBRARY}
|
|
)
|
|
|
|
install(TARGETS epsonscan2 DESTINATION ${EPSON_INSTALL_ROOT}${EPSON_INSTALL_PATH})
|